IGEL OS licensing not activating


Working with a new UMS deployment, UDX3-LX with FW of 11.01.100.01, no internet access for ALD. I created UMS Licensing ID, added pack, added hardware, downloaded license file, injected into UMS. I can see license file shows order number, maintenance category, pack id, and exp date. I can click on hardware and jump to the three devices, all are linked. None of the 3 are activating…and we have 3 buildings to fill of these coming up soon (these are our POC deployments)

Upgraded firmware to latest, still not assigning and now its just saying ‘Waiting for license…’

ran journaling, shows value not found at some point.. for what/why i don’t know


I would highly suggest to update the endpoint to 11.04.130, since the License deployment was a bit buggy in early stages of the firmware.

If that doesn‘t work, reset the devices to factory defaults and check that the ports 30001 and 8443 are opened from endpoint to UMS.


FYI, usually when the license is assigned but not copied to the endpoint, it’s possible to trigger the activation by sending Other Commands > Settings UMS to Device via the device right-click menu. If that doesn’t work, there could be a problem with the license file or a communication problem between UMS and device.


I have upgraded to 11.04.130 and then 11.04.131, no such luck. Tried resetting to defaults, verified ports are open as the devices use IGENRMSERVER to check in, they used 8443 to upgrade firmware.


can you share the content of

/license/dsa/licences

from a local terminal?


I will once my coworker gets back onsite and can get me into the network (secure network, lots of hoops to go through). Also FYI I was able to create browser session and browse to server:8443/ums_filetransfer and got login prompt so the device can at least get over to the location.

thanks, tried that first as well, that’s the puzzling part. That’s what led me into checking journal to see what was going on via the console. Very odd!


Great! Thank you!

Just in case is there an AV on the UMS server? Could you disable it too and retest?


Confirmed no AV, they use Cylance and I was stern about disabling it for testing 🙂. Ha!

Here’s a screenshot of device 1, 2 and 3

I nano’d a few and its the LIC files from the UMS server..

so it appears its pulling the license files down


Weird… Can you try to delete the local lics, reset to factory defaults and reregister?

You can use the command line and run the following command:

`mount -o remount,rw /license; find . | grep -iRl “.*lic” /license/dsa/licenses/ | xargs -I {} rm -rf {}; mount -o remount,ro /license`


let me try now! one moment

completed, factory set, checked into ums using dns name, license file now appears on device, ums still shows no valid license


Hem… Ok… I know it sounds weird but could you delete the licenses from UMS, download it again from the ILP but with a different browser (I know, but it makes a difference).? Please delete the license with commands sent before.


I can try, would be third time doing it (did that prior to posting)

Any particular browser to use? On the device I’m on is Chrome


I‘m using firefox!


I’ll give that a go and see, will follow up when I can confirm one way or another, engineer had to run to lunch

@member we got it resolved! Come to find out they were using the VMRC to copy the data in and out to the VM since theres no direct network access, and the VMRC must have been messing up the text/data somewhere. Got them to move the file in using a USB drive and some questionable mounting tactics and its good to go, devices came up almost instantly


Wow… That‘s great to hear @member !!


Definitely a new one for me, ha! Much appreciated on the assist!

Continue reading and comment on the thread ‘IGEL OS licensing not activating ‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: