IGEL OS not seeing my second monitor?


Hello everyone. I am an employee of a company who uses the igel to access the remote work station. My problem is that I have been unable to add a second monitor while connected to my remote workstation on igel. Dual monitors otherwise work fine on my home Windows. I had been using an iMac but had to purchase a Dell Inspiron i7 PC along with 2 monitors because my Mac no longer performs well on the remote. The company techs thought it was the igel and sent me some igel replacements to see which would work, 4 in all that were more updated. Not one of the more updated igels worked and received a prompt that there was no detectable bootable device. I ended up having to continue using my original igel which allowed access to the remote but again was unable to detect the 2nd monitor. I tried the settings several times but the access for “all monitors” was grayed out. Our techs mentioned that access to the settings for a 2nd monitor is across the board but not in my case. Our techs, although they tried best, don’t have an explanation for this and thought it was my PC but I asked Dell and they were unable to help. I wonder why the newer, more updated igels did not find the bootable device. Does anyone have a solution for this?


Hello Maria, first of all, let me ask a few questions:

which igel OS Firmware are you using?

which igel Device are you using?

so you you are using Igel OS locally and trying to access a PC remotely via RDP, right?


Please let me get back to you later in the day. I am now getting ready for work.


Thanks for reposting this @member. I will delete the other post in Chit-Chat. We will do our best to help! 🙂


Had a couple moments to take a couple pics. The one on paper is the one I’m using. The ones in the packets are the newer ones but get back after 2:00 central.


Unfortunately, any settings within the IGEL OS are probably managed by your IT team and wont be editable by you. If you have access to the “display switch” application, you should be able to determine if the 2nd monitor is being detected or not.

Just to confirm, none of the new IGEL sticks work in your new computer? Does the old stick? You may need to go into your bios setup and allow USB booting or increase priority for it above your hard drive.

It could be that your new computer is in legacy bios mode and not seeing EFI boot sources. This is not something an end user can easily change while an OS is installed though.


Hello. Yes the newer updated igels do not work and the screen reads that it couldn’t detect a bootable device. The old one that I have been using for over a year works on my new computer but once on the remote, I cannot add the 2nd monitor. There is an option for “this monitor” and “all monitors” but the “all monitors” option is grayed out and can’t access. I don’t understand why the old igel continues working but the new ones do not.

I was looking at the bios and please understand I have no technical knowledge but under secure boot mode, the deployed mode is selected. The audit mode apparently performs a signature check but does not block execution of all UEFI drivers and bootloaders. Is there a possibility that it needs to be in audit mode?


I run an HP shop, so I am unfamiliar with the Dell bios settings, but maybe? IGEL OS has been signed for secure boot for versions after 04/2018 so I would expect it to work with it turned on.

Please also understand, it is difficult to give recommendations to an end user who does not understand the impact of what these changes entail. Especially when that user works for a company other than my own. I would assume most that join this community are administrators of some type. And in my personal opinion, your support should really come from within your company for devices that they deployed.

If my company were deploying UDPs for remote work and I had a user who couldn’t get it working, I would probably just send them home with a preconfigured UD2, rather than waste the hours of troubleshooting.


I decided to bring up the bios and decided to uncheck the secure boot which was something recommended after doing a bit of research. That did not work so I enabled it again. I then decided to change the order of the boot to windows bootable first and then igels as secondary. I tried once again and this time the other versions of the igel appeared on the menu after using the F12 key. I clicked on the one of the new versions and was able to access the remote which also immediately brought up the 2nd monitor! Very strange but problem resolved! Thank you for your time!

I’ll add that I contacted you only because our techs and the Dell company couldn’t help. At the end I’m happy to have been able to resolve the problem. 😅


Well in the end, I am glad you found a solution that got it all working for you! And I am sorry your other tech support options couldn’t help you out. Seems like you were able to figure a bit out by researching, don’t tell anyone, but all we do in IT is google the problems 😉

Continue reading and comment on the thread ‘IGEL OS not seeing my second monitor?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: