IGEL OS stuck “Connecting LAN DHCP” after update to OS 11


Has anyone had an IGEL that gets stuck on Connecting LAN DHCP after an update to OS 11? The network port is working on other devices so it’s not a cable/network port issue.


On which version of IGEL OS11 ? Which kind of hardware (client type) are you using: Igel, virtual oder other vendor? Does it work if you specifiy an IP manually:


Resolved it by swapping switch port. Odd one as it worked in my laptop before the swap.

Thanks


I’m seeing enough of the “Connecting LAN DHCP” to have me worried. We’ve upgraded lots of devices from 11.02.152 to 11.04.110 and some of them get stuck on the DCHP message after the upgrade. These are all remote ICG connected only devices. And reboot after reboot doesn’t fix them…and they were confirmed to be working prior to the reboot. Any ideas?


What would a

journalctl | grep -Ei ‘dhcp’

gives back when a device get stuck on DHCP?


Thanks, I’ll keep that in mind, however I cannot normally execute these commands when the user is having an issue. So far I’ve witnessed these failures as such: they happen during the firmware upgrade (with the firmware upgrade still not fully completed) or after the firmware upgrade is complete. My conclusion thus far – 11.04.110 seems to be less tolerant of network cabling faults than 11.02.152 was. Most issues seem to be resolved once I swap the network cable to another. Most issues seem to occur with cables that a bit longer (16 – 100ft) than the cables that are normally included with users IGEL’s.

I’ve seen situations where a Windows 10 laptop will negotiate a “1000base-T FD” connection when directly plugged into the ISP modem. The same device then negotiate a “100base-T FD” connection at the end of the long run (I suspect some sort of faulty network cable). An IGEL UD2 device running 11.02.152 was ok on this run as well, but after upgrading to 11.04.110 the device refuses to connect, and a dialog window that stays on the user’s desktop indicating:

Network

_Connecting_ …

LAN DHCP

I’d like to get my hands on some of these cables, so I could test on my own unit. It’s been very difficult to isolate as these are all ICG units, and all in the users’ locations.

Continue reading and comment on the thread ‘IGEL OS stuck “Connecting LAN DHCP” after update to OS 11’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: