IGEL UD6, trying to get 4K working over a KVM switch but the display settings shows connected through wrong HDMI vs Display Port?

Hi, we have got an Igel UD6, we’re trying to get 4K working over a KVM switch however this seems to be failing? The display settings show that the thin client is connected through HDMI? What could be causing this and what would be the best way to fix?

Learn more, read the entire thread inside the IGEL Community o Slack

Do you use Displayport?


Does it work without the switch?


The thing is where igel is detecting the connection as a HDMI connection?

🙂 Okay, i think its hard to solv it. If i understand it correctly the IGEL identify the kvm switch as HDMI Device. Maybe you can do some crazy stuff in the Firmware, but i dont have any skills in this.

i think its based on the device you connect to it

Also the product specs of the igel show max resultion is 2560×1400 and not 4k. However if i connect it directly to the display it works fine on 4K

@member We tried with other devices on the switch, but they seem to work fine. I tink somehow either the 4K resolution or 30Hz is not enforced correctly? and that is preventing it from working?

sounds strange. Maybe contact the IGEL support. 😉

@member I assume that you are using Linux. Can you share the firmware version? You may try to set the Resolution manually under User Interface => Display (don‘t forget to set the right connector HDMI) and the deactivate the Display Data Channel (DDC) edocs.igel.com/#2703.htm

I know that the support will have some issues to solve it because it‘s not supported but you can give it a try.

One last thing: did you checked the display port cables versions to ensure that there isn‘t an issue with the DP Version?

@member Thanks for the response, We checked both cables by directly connecting them to the display. This both gave us a 4K resolution. Another question is, you say i should choose the right connection HDMI? But HDMI is not used? it’s displayport?

When disable the DDC, the system returns no screen at all, just an “empty shell” as its waiting for input

Yes, I mean: go to Start => System => Identify monitors and take this value for your profile!

Alternativ: in a new profile you may use the display switcher to check the supported resolutions =>Accessories => Display switcher => add it to the Desktop => then Option => choose advanced mode in the pulldown=>assign and open it on the endpoint

Sometimes Display port is recognized as HDMI, don‘t worry about that.

Okay, but thats what I tried. The display shows 1920×1200 (3840×2160)

I then tried setting the resolution at the display settings by sliding the bar all the way to the left, the 3840×2160 resolution shows up, i click apply.

After that the screen flashes a couple times and no changes were made visually

I’ve reset the Igel (even with direct connection) and disable the DDC returns in a “waiting shell” where i can not do anything

Ok, then, try to get help at our support. I kerp my fingers crossed

Hi guys, old conversation, but just wanted to share that the UD6 doesn’t support 4K. 2560×1600 is maximum supported resolution. To get 4K support you need to go by UD3 or UD7.

Continue reading and comment on the thread ‘IGEL UD6, trying to get 4K working over a KVM switch but the display settings shows connected through wrong HDMI vs Display Port? ‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: