IGEL UMS environment stopped working

Our IGEL environment was working this morning but now it isn’t πŸ˜• and i need to add 4 new clients today but now i can’t do that

Learn more, read the entire thread inside the IGEL Community o Slack

Try to close the GUI and restart the UMS Service: IgelRMguiserver by opening services.msc

I Tried to restart the services but it’s not saying stopping and he is standing for 30 minutes how to fix.

it’s server 2012

Server reboot seems to be the only way, if not possible send me a PM

I found it already πŸ™‚ www.gfi.com/support/products/how-to-manually-force-a-service-to-stop-if-not-responding

Sorry for asking to quick

Server restart seems to work right know!

Thank you for all the suggestions

Sorry the issue is back again πŸ˜•

What did you do exactly before the error? Did it work a few times then not? Is a Antivirus Software in use?

I did nothing and yes we have Bitdefender but same program was also in use before this error

What do you mean by nothing? Please describe what you are doing in more accurate manner: did it happened during a profile assignment, registration, …?

This error that you see above that is what i get if i want to assign an client in to an specific folder this morning everything was fine. but now in the afternoon i tried and then it’s not working and i don’t know why

If i do the registration on the machine itself than it’s working!

But if i want to register it on the computer then it’s giving me this wierd error

So a registration Client=>UMS works, a Registration UMS=>Client not. Right?


This is probably not very helpful, but a refused connection usually means (in my experience) that a daemon/service is not listening, or that a firewall blocked the connection… or perhaps for some reason (D.N.S., et cetera), a certain part of the connection is not working, or something is trying to connect to the wrong thing.

@member did you checked the ports?


In 99,99% what you described in your last 2 messages, the TCP Port 30005 is not reachable from UMS. Can be a antivirus, network or firewall issue,



Please let us know what you found out, regarding the port check. If they are opened, try to disable bitdefender, Windows Firewall

Port 30005 was not the solution

And… what did you found out?

I will try other solutions later.

Gonna get my stuff and go home!

Ok, but give us a feedback on the ports in general: 30005, 9080, 8443, etc… are they opened?





This are the ports opend ans also now 30005

I assume you considered the directions, a.e.: TCP/UDP 30001 UMS<=TC, T/U 30005 UMS=>TC or T8443 UMS<=>TC

Are any firewall logs available? If not, maybe you can try probing the ports from the U.M.S. to the thin client and vice-versa (using netcat/nc/telnet/probeport)?

(using Sebastien’s documentation, of course, of which ports are used and in which direction)

I just sended the information to my collegue so he can check in our Company USG if everything is fine

@member, I’m getting confused on @member write up.

Tc must have possibility to reach UMS on 30001 = open 30001 incoming to UMS

UMS needs to communicate on 30005 to TC= open 30005 outbound from UMS.

This is the least requirements to add devices to UMS.

TCP inbound to UMS and UDP +TCP outbound (UDP is not required, but easiest up when scanning)

Then you need at least 8443 inbound to the UMS for filetransfers and console on current versions of UMS.

More info to find at:


@member Right, I wrote too fast, corrected. But the docs attached to my posts were rightπŸ₯Ί

I am busy emailing with my collegue but i think we gonna solve this problem quick! Gonna see if it will work tomorrow

I keep my fingers crossed, would be happy to help if needed

The Problems are solved πŸ™‚ There was 1 double NAT rule into our Router. that was causing this error

Also the TCP/UDP Procotols were not right

Happy to have the issue solved! I wish you good luck for your last 4 clients

Continue reading and comment on the thread ‘IGEL UMS environment stopped working’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: