IGEL UMS Error: “Internal error: java.lang.NullPointerException See log files for details:


Just saw a weird behaviour in my lab. Maybe this post helps if you encounter it yourself.

Used default settings on Universal Firmware Update (UFU) in UMS 6 and downloaded latest IGEL OS 11 firmware. Tried to update my Thin Client. Not working of course because I use ICG. (RTFM I know.) So I set an FTP server, deleted the downloaded firmware from UFU and tried again to check for new firmware in UFU.

From now on I received an Error ⚠️ every time I tried to check: “Internal error: java.lang.NullPointerException See log files for details.” No reboot or prayers helped.

Then I realized the deleted firmware was still in the recycle bin. After removing it from there, the error disappeared. So basically if you have an error ask yourself: Have I emptied the recycle bin?♻️


Good one, yes, it happens in this specific cases and the error message doesn‘t help that much… Thanks!!!


I learned quickly to clean the recycle bin after deleting an object I know I want gone haha 🙂

Continue reading and comment on the thread ‘IGEL UMS Error: “Internal error: java.lang.NullPointerException See log files for details:’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: