IGEL UMS license error “The UMS has no license for this thin client”?


I have an issue with an IGEL in UMS not taking the license. This started with getting the message below when getting the Citrix applications. You can login to the terminal with no issues. I refreshed the terminal’s settings, verified the Storefront address was not changed, reset to factory defaults – even deleted from UMS and re-added. After the reset and re-adding, the status notates “The UMS has no license for this thin client”. But when you scan for terminal, the Certificate is stored. But, I still get the same message above. No other terminals are experiencing this issue at this time.


We had a similar issue with a thin client today. I ended up resetting the device, removing the device from ums (including deleting from the recycle bin), removing the license in the activation portal (using remove hardware), synced licenses in ums, and then letting the device find ums and add itself back.


Thank you David. I will duplicate these steps and give it a try.

Interesting. I tried this and still have the issue.


local license files are relatively sticky and persist even after factory reset – try the following via ssh/secure terminal as root:

mount -o remount,rw /license

find . | grep -iRl “.*lic” /license/dsa/licenses/ | xargs -I {} rm -rf {}; mount -o remount,ro /license

mount -o remount,ro /license

shutdown -r


@member To add to what Josh said above, it seems this device does not have a license or has a defective license. We might have to remove the license manually and get it relicensed to see if that helps.


@member tried calling you 🙂 I can’t get the CMD line syntax to work. I was able to finally remote shadow in.

@member Hi can you tell me how to run those commands? Like step 1, step 2, etc? I am not a Linux person. Is it line by line, or the entire thing?


that should be line by line, but I don’t think the line breaks came through correctly – give me just a second, I think I can turn that into a one liner 🙂

1. Open a secure terminal session as ‘user’

2. Elevate to root using ‘su’

3. enter the following, all as one line: `mount -o remount,rw /license; find . | grep -iRl “.*lic” /license/dsa/licenses/ | xargs -I {} rm -rf {}; mount -o remount,ro /license`

4. Reboot the thin client


I keep trying and get this see screen shot.

mount -o remount,rw /license; find . | grep -iRl “.*lic” /license/moundsa/licenses/ | xargs -I {} rm -rf {}; mount -o remount,ro /license

when I type that in, I get half of it cut off

should I try SSH instead?


The text is most likely wrapping around itself but should still execute if you copy the entire thing – SSH should be a little bit better in terms of readability

make sure it’s /license/dsa/licenses as well


One issue I had that caused licenses not to come down, was the time being off in the Bios. Thats one thing to check 🙂


Thank you to all who replied to this. Lots learned here. FYI the fix I have found to work is the time being an issue. Not the Bios, but the IGEL terminal had the wrong NTP server settings applied. Once we corrected this, it resolved the issues.


gtk, thx

Continue reading and comment on the thread ‘IGEL UMS license error “The UMS has no license for this thin client”?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: