Installed IGEL OS 11 on Windows 7 IGEL thin client and now no applciations show up, why?

Evening folks, we just tried imaging IGEL OS 11.02.150 onto an older Windows 7 IGEL – an M330C – and while the installation completed without any trouble, there are no sessions available to create at all, even when the device is moved to a folder with no profiles or customizations attached at all. I do see that the M330C is not listed on IGEL’s supported devices list, but this lack of functionality seems at odds with:

Learn more, read the entire thread inside the IGEL Community o Slack

1. The install completing successfully

2. IGEL OS being labeled as “platform agnostic”

3. The IGEL OS product page implying full compatibility with both x86 and x64 based devices.

Have any of you had any luck with this at all, or any suggestions on why the sessions/applications are unavailable?

Link to the supported devices list for reference:


Yes, the M330C is not part of the support matrix anymore but in this case – Does the device have a valid OS 11 (WE) license on it?

Not yet – I had wondered if the license being missing would cause sessions to not load, and discounted it as we have some M340Cs without licenses for testing which are working without issue so far. Do you think that applying a trial license could ‘enable’ sessions and the like?

Without a valid license on OS 11 the sessions are not available. On older versions of the firmware they were available, but most likely wouldn’t work even if configured.

Yes, a valid Demo License should work and you can test.

Interesting – thank you @member @member – I wonder why the devices without a license are working ok? I will test and report back to you guys. Appreciate the assistance!

That is strange – if the device is on OS 11 – it needs a valid WE license to function. Are the older devices in question Windows or IGEL OS 10 devices?

They were a mixture of 7, 7+ and Windows 10 – with one IGEL OS 10 in there for good measure. It’s quite the collection… The 7+ and W10 with IGEL OS 11 installed did not require trial licenses and worked without issue. I have trial licenses on some others, but there are a couple I set up to demonstrate to the guys deploying it and did not hassle myself with the licenses there and then. The Windows 7 unit on the other hand wouldn’t do anything.

I just applied a trial license and – bingo – browser opens up. I will test some more tomorrow to verify Citrix is also working, and report back. Thank you both for the quick help!

That’s great!

Continue reading and comment on the thread ‘Installed IGEL OS 11 on Windows 7 IGEL thin client and now no applciations show up, why?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: