Is it possible to save a PDF file on the desktop and open it on IGEL OS?

Hello everybody, I just have a short question.

Learn more, read the entire thread inside the IGEL Community o Slack

Is it possible to save a PDF file on the desktop and open it?

Hello Leon, you could use file in UMS, and Deploy the PDF to /userhome/Desktop/

If I use your path, there ́s no PDF file on the desktop.

Can you check in Terminal if the file arrived there? If not, transfer it to /wfs instead and link it manually (for testing), by issuing:

ln -s /wfs/yourfile.pdf /userhome/Desktop/

It ́s arrived, but will not displayed at the desktop.

Might be related to the fact that we need a link instead. did ln -s worked?

If that doesn‘t work either: Create a CustomApplication:

System,Firmware Customization,Custom Application with a command like

evince /wfs/yourfile.pdf

If I configure a custom application like you ́ve said, I get a error message and can ́t open the document.

the path looks a bit weird… Cannot check atm. but what happens when switching to user

su user

and start the evince with the command from terminal?

After check the path, I get the following error message.

started as user?

Have you by chance disabeld Cups Printing (from _System > Firmware Customization > Features_)? If yes, then pls re-enable. There be ~dragons~ libs to render PDFs.

Was on a customer site until now… I just tried

evince /wfs/sample.pdf and it worked.

Firmware 11.03.100

Can you check Jo’s suggestion?

I ́ve tested it and activated the feature (Print [Internet printing protocol CUPS]), if you mean that. But i get the same error message. Is there another feature, that I have to activate? I deactivated all features except the recommended features.

Which Firmware version are you using? Can you try 11.03? Can you test this pdf instead?

Oh, and just for testing: can you remove the profile where you deactivated all the features? Just to see if that helps?

I use the newest firmware 😄 But I will testing your hint later. We have now a bigger problem, I write a new post here for that problem. 😕

If I activate all features, I have the same problem. Will the features installed/activated after a restart? If yes, that fix not the problem, at least for us.

Yes, if a universal firmware update is assigned. You can open a local Igel Setup and double check if all Features are ticked. Did you had time to test my PDF?

Now I had time for testing it with your PDF and the result was the same. I get the same error message.

Ok. Time for spontaneous Teamviewer Session? Can you send Teamviewer ID and PW as PM?

Now it works. Many thanks to @member and @member. After activate the feature CUPS not by default, rather activate the parameter manually. Now I ́ve a another question. Is there a possibility to configure the document viewer. Meant: Lock some interactions, like the “Open”, “Save”, “Print” or lock/invisible some menu items and configure the standard parameter like the standard zoom etc. ? I ask because we don ́t want that the user has access to the igel file system or to interact with administrative menu items.

You could try evince -s /wfs/yourfile.pdf

-s should be presentation mode.

Yes, that ́s right, but not necessarily the solution. Because the user should jump between the sites and use the index.

Continue reading and comment on the thread ‘Is it possible to save a PDF file on the desktop and open it on IGEL OS?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: