Is there a way that they only have Citrix icon in IGEL OS, fill in credentials and done?


Hi all, we have a customer that just updated there devices from IGEL OS 10 to IGEL OS 11. They had troubles with creating a Citrix session, (because a little div in OS11) now they managed it with “Citrix Self-Service” but they are running into the issue that the customer that wants to loggin to citrix now has to do multiple things instead of just login and done. They nw have 1. double clich Citrix icon 2. workspace mask opens and the enter credentials 3. the “desktop” app must be added (once) 4. start the “desktop” app. Is there a way that they only have citrix icon, fill in credentials and done ?


Hi Sander, which versions are you using exactly? Can you forward a few screenshots?


11.03.100.01 is the firmware they are using

and here is the profile they use


I would uncheck the Multiuser feature which should help a bit:

in a second approach, I would consider an update to 11.04.200.

There you can switch to Apps and use everything without the need to go to Submenus:


Thanks, we will contact the user.

Continue reading and comment on the thread ‘ Is there a way that they only have Citrix icon in IGEL OS, fill in credentials and done?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: