Is there any way to edit the IGEL OS device IP?

Is there any way to edit the device IP? We have some devices temporarily going to a different network and would like to manually update the IP in UMS.

Learn more, read the entire thread inside the IGEL Community o Slack

Checkout the following screenshot on the IGEL Community in Slack?

Sweet -ty!

Is there an advantage to doing it in the registry? It’s in the normal network settings, but one must choose ‘Specify an IP address’. I wonder whether the registry method would try to lease that specific address from D.H.C.P. without making it static?

Wait, I just changed it and that corresponds to the Network>LAN Interfaces>InterfaceX>Specify an IP Address setting. I needed to be more specific.

You can change the ‘Last IP’ in the device information by double-clicking it. I think that you mean something else, though?

What I am looking for is an employee moves device to a completely different network that does not share DNS. What I noticed is that if I trick the “Last IP” to be the same as the new destination, UMS sees it as there is routing between the networks. However, if it has a different IP and I don’t “Preload” it with something on the new network, it never sees it.

@member – When I double click I cannot change it. This is UMS 6.05.100

Also – this device will not be long before it comes back to the original network and will move back and forth.

@member could you check if 1) igelrmserver is resolvable on that networks 2) port 30001 is opened from endpoint=>UMS?

DNS resolves it now but 30001 appears blocked. Thanks for this all of you – I need to remember my basic UMS setup!

@member: @member ist thinking of the LastIP field in the UMS, this one cant be changed via UMS anymore.

This also does not configure the IP Adresse of the device, it only Shows the Last IP of the device which the ums knows of.

I thought it used to change. That is ok though. I think the better solution is opening 30001 between the 2. I have a request into our Network person.

What a day. From our UD3 I can get to the UMS server over 30001, however, from the UMS I cannot telnet into 30001 and nmap shows it closed. Our network guy bypassed the firewall. I do not see 30001 in netstat or ss on the IGEL UD3, nor does it show up scanning the device from the UMS server with nmap. What is the best way to make sure it is open? I tried ufw but it does not appear to be installed.

The UD3 works fine when it is directly on our networks, but as soon as it goes to vpn through openconnect in another location port 30001 appears to be fine from the UD3 to the UMS server, but does not work from the UMS server back to the device.

Oh, that‘s a different story. 30001Tcp is for Endpoint=>UMS

30005Tcp is for the way back: UMS=>Endpoint

Ah! I needed that piece of this puzzle.

30005 is showing connection from UMS>Endpoint.

Ok, that‘s great! So both directions are opened for communication, right? Then please reboot one device, wait until bootup, press F5 in Console and see if the device shows up. If not, or if offline but IP Address matches, please come back to us👍

I am really wishing we still had the “Change the last IP” feature now. But I am curious – how does the UMS “See” the devices on a network? Does it require DNS?

do you mean in general or when clicking the scan for devices button? If in general, the clients connect to the UMS server on boot and receives the ip information and such. After that, i am not sure, but assume there is a timing interval that either the client checks in or UMS reaches out to get an updated status.

> I am really wishing we still had the “Change the last IP” feature now

Since this feature removal is a recurring annoyance, i created a gist to show how to approach this using Powershell/API/PSIGEL:

> how does the UMS “See” the devices on a network? Does it require DNS?

afaik – the UMS gets updates on the devices only at device startup, when the device is contacting the UMS for updates on its configuration.

The UMS itself scans the devices (only ? when viewed/scoped) according to the setting under Settings -> Online check by using its known IP address which it got from the device on startup.

If for whatever reason that startup-communication did not succeed, the UMS keeps assuming that the device is still operating on the known IP.

@IGELfolks feel free to correct me here

yes, on startup and regularly during uptime. The device during bootup tries to contact the UMS by resolving igelrmserver, then gives back the actual IP through TCP 30001 to UMS, by issuing write_rmsettings

The UMS only tries to contact the device for Online State check by UDP 30005

Hope that helps!

> and regularly during uptime

do you have more specific infos on that?

every 30-60 min from what I recall.

Is there anyway to force the UMS update from the device that normally happens during the bootup? Launching VPN after it boots may be missing the write_rmsettings because the VPN connection to the network comes after the boot. It would be very useful in testing to be able to force the device to contact the UMS on demand as needed by a terminal command or other method that resolves igelrmserver and gives back the actual ip through TCP 30001.

try “get_rmsettings” : Get UMS config (reboot to apply)

“get_rmsettings” from the endpoint worked! Thank you! No reboot was needed – Last IP changed to the VPN IP and it is green in manager! Thank You @member!

Continue reading and comment on the thread ‘Is there any way to edit the IGEL OS device IP? ‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: