Issue with black screens when users are reconnecting to a VMware View session?


Has anyone had issues with black screens when users are reconnecting to a view session? We have their session disconnect after 15 minutes so we can engage MFA via the VMware Client.

It isn’t happening to everyone, but the handful of people it does happen to, happens quite often.


Hey @member, my experience in the past is that a black screen issue on Horizon is an issue with the display driver from the Horizon client. Did you by chance upgrade you VMWare Tools recently?

Also, what version of Windows 10 are you running on the VDI side?


We are on 7.10 agent I believe. WIndows 10 LTSB is what our VDIs currently run on.

I’m going to try and recreate this on a seperate linux machine, but users haven’t complained of this happening when working from home on their own equipment


Check to see if the VMWare tools were installed/re-installed at a later date than the Horizon Agent


My guy says this “they were and in the order prescribed by vmare.. tools first then reboot then agent and reboot”


OK, just making sure. Thanks. From my previous life, I know, normally the black screen issues have all been something in the image.


Yea, we do have a ticket open with vmware and have tried things around that. Like even enabling 3D graphics. no luck yet

We’ve also tried both Blast & PCOIP


Interesting, does the session sit on a black screen for 15~30 seconds and then disconnect, or is it just going black randomly?


So they work fine, then I have a rule set to kill the vmware session after 15 minutes of idle so they have to re authenticate. When they reconnect, this is when they will see the black screen. But its only for probably 5-10 people. VMware will see them as connected via View, but it’ll just be a black screen. We can also see all their programs up when we console into the vdi


With this 5-10 unfortunate, do they have the same reconnect problems when they properly disconnect instead the client being killed?

The hypothesis here is that a too rashly killed client might leave host or remote side in a bad state.

How do you kill the client exactly? I guess a safe way to do it is to send a SIGHUP to the vmware-remotemks process. When you start the vmware-view with the once-option (available in the registry) then the whole client will end automatically.


I have also thought the killing of the session may be the cause as well. How do you exactly go about doing the last part you are talking about? I’m not sure I quite understand @member


Hey @member by chance are you an Imprivata shop?


Nope.


How are you ending the session now @member? I looked through the documentation from VMWare, and don’t see a shutdown command on the linux client like there is on Windows


I’m using this,


Yea, I wouldn’t think that would be a great way to do it


I’m up for suggestions 🙂


Try at least killing vmware-view and vmware-view-crtbora-bin

kilall vmware-view; killall vmware-view-crtbora-bin

I am looking to see if there is a way to call the disconnect direct


The closest thing to a disconnect is the killall -HUP vmware-remotemks. This is the binary that renders the session.

And with the once-option the whole client will quit gently. This can be set in the registry either globally in vmware..once or in the individual session (cannot check now, out-of-office).


Awesome find @member much better than ripping the resources away

I would say give that a try @member and let us know if you don’t mind 🙂


Thanks guys! So I should put killall -HUP vmware-remotekms instead of what I have?


Yea, give that a shot


Thanks!


Not sure why there isn’t a shutdown command on the Linux View Client


That would make too much sense 🙂

It doesn’t appear to kill the session

shoot i mispelled the command

Looks like it killed the session, So i’ll put these peoples machines in this group and see if it happens again.

thank you!

Darn, looks like it still occured with the new command in there

@member is this the command you were referring to


Right, vmware.view.once

It’s always set in appliance mode, but not the default in desktop sessions.


Ok gotcha. thanks!

@member What if we did the disconnect on idel from the vmware side, and used the once command to close the session. Article on idle disconnect: robbeekmans.net/uncategorized/disconnect-vmwareview-vdi-session/

i’m testing it out to see if a schedule task could work


Right on! To do the idle timeout disconnect by the remote session was also my preference but being a linux guy, i didn’t know how to do it exactly. Thanks for the link!


You’re welcome 🙂

Looks like this will take some figuring out. The command runs fine outside of a scheduled task but doesn’t want to run in one. I’ll update you guys on it when i figure that out

Needs to run as domain Users

Continue reading and comment on the thread ‘Issue with black screens when users are reconnecting to a VMware View session? ‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: