Issue with VMware Integrated Printing and CUPS is limited to black/white only on IGEL OS?


Aloha,

I’ve got some issues with VMware Integrated Printing and CUPS. I’m hoping someone can verify if i’m doing some things right on the IGEL side of things.

Step 1. In UMS, added the PPD, specific for this exact model printer, to “Files” and attached it to the thin-client

Step 2. Created a profile for CUPS printers and attached it to the thin-client

Step 3. Logged on to the VDI session and i can see the printers are installed

Result: Printing is limited to black/white only, even though the PPD is specific for the printer model. Attempting to access “Printer Properties” results in an error VMWARE POSTSCRIPT xx printer driver not installed.

According to the articles: VMware Integrated Printing should attempt Native Printer Driver (NPD) first and then fall back to a Universal Printer Driver (UPD)… unless you alter this behavior via GPO (which we didnt do). It looks like this step is not happening and the VDI session ends up using some half broken driver.

I think i did the IGEL stuff correctly, but i’m happy to try different things if someone has suggestions.

Thanks for everyone’s usual support!

Quick update for those interested:

Connecting to the same VDI session, with a Windows Horizon client, with a local printer installed, results in the expected behavior of showing the printer with a VMware Universal driver installed.

Perhaps the issue is related to the Horizon Linux client?


From the VMware guide

For Network attached printers –> After a printer is added on the local client computer, Horizon Client adds that printer to the list of available printers in the remote desktop. No further configuration is required. If you have administrator privileges, you can install printer drivers on the remote desktop without creating a conflict with the Virtual Printing component.

docs.vmware.com/en/VMware-Horizon-Client-for-Linux/5.4/horizon-client-linux-user.pdf

Sample Profiles for Network printing can be found on IGEL Community GitHub site:

github.com/IGEL-Community/IGEL-Custom-Partitions/tree/master/CP_Source/Tools_Drivers


It’s no wonder that when you connect from a Windows client that the EMF drivers are likely used. For unixoid clients using cups a Postscript based driver has to be used if I’m not mistaken. Have you tried to print locally from IGEL-OS (eg using the browser) to see if your ppd is working, @member with color and all? At least the docu says it should be possible to get the (all?) features of the printer across to the desktop.


Thanks both! I have read the Horizon client documentation, there is not much to configure for VMware Integrated Printing.

I will test the local printing outside of Horizon (probably use FireFox) first thing tomorrow and report back.

One thing I did try just now, to rule out any issues with the PPD i was using: Created a fake CUPS printer using a printer driver that is pre-populated in UMS. Still the same problem.

Continue reading and comment on the thread ‘Issue with VMware Integrated Printing and CUPS is limited to black/white only on IGEL OS?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: