Issues with redirecting a Yubikey on the IGEL OS

Hi All, I’m having issues with redirecting a Yubikey 5 on the iGel. We have made sure that we are allowing the redirection on the view client end. I have tried using Secmaker Net iD and Cool Key and Open SC but have had no luck. EDIT: Using PCOIP and 11.03.100

Learn more, read the entire thread inside the IGEL Community o Slack

Can you show your USB Redirection Profile for Horizon please?

Can you deny the Yubikey also (in your USB Redirection rules), reboot and retry to use the PCSC Config?

Yep that didnt work 🙁

Ok, let me ask: for which purpose do you plan to use the Yubikey?

we are trying to redirect it for use with a client site

I see the USB part

just not the smart card portion

Is there maybe a second USB ID, for that device? Did you tried to connect it without having a session started and issue lsusb in a terminal?

I looked at the USB ID and only saw one

and I did a fresh session for testing

Hello @member you may want to deny USB Hubs. Normally you don’t want to redirect anything but the specific devices you need in the session.

As for Yubikey, I thought they used a different protocol that is not in line with smartcard technology?

Denying USB Hubs didnt fix the issue.

we were discussing with @member internally, and I got it working in Firefox for a 2FA on Citrix… But not on Smartcard related channel… Is everything else getting redirected?

Yep everything else but smartcard but sadly this smartcard functionally is what we need for this site.

Dumb question maybe… Does it work on a Windows Client with Horizon?

Yes it does.

@member does it show up at all in the VM?

Just found this article (not Horizon) but curious if it applies here.

That is for the vmware player. 🙂 I will try to see if the driver leads to it showing thou.

ya its not detecting in device manager

so i cant apply the driver

Even if it‘s an additional cos licence, you could try to use the Fabulatech USB Redirection instead… I will PM you a Private Build with a newer Horizon client version, if that doesn‘t work either… I haven‘t more ideas tbh…

I downloaded the private build

and put it on a test igel and it didnt work


i put in a ticket with igel support yesterday

so hopefully i will hear back

@member the Yubikey should be using the pcsc channel, so there should be no usb redirection enabled for that device. I have not tested with the Yubikey 5, but previous versions and they show up fine as a smartcard in IGEL OS,

1. What you could test, select NetID as a middleware

2. Insert the Yubikey

3. open a terminal and run “iid”

4. in the menu appearing, select your Yubikey

5. in the menu appearing select 5 (list certificates)

6. do you see any certificates?

Should look something like this, (my yubikey doesnt have any certificates installed)

Thank you! Totally showed up!

Continue reading and comment on the thread ‘Issues with redirecting a Yubikey on the IGEL OS’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: