Microphone is muted, and when I try to unmute via the keyboard the light never goes out?


I am having problems where on my HP elitebook the microphone is muted, and for some reason when I try to unmute via the keyboard the light never goes out. How do I fix this. IGEL turns it on when it loads.


Could you provde an exact brand of your Elitebook? Which Firmware are you using?

Is the Mic muted on HW Level or in Software? I mean, can you unmute in the local sound mixer?


HP 7WZ86UT#ABA

The sound is turned up to 100%, and I am assuming it is a hardware level issue, firmware 11.04.200.01


If you open a Local Terminal (Accessories, Terminal, +) login as root, does this command issues what you are looking for?

“`xdotool key F20“`


Is that a 7G HP device?


G6 from what I recall.


Ah, nothing but trouble with the G6 devices.

I would recomend testing 11.04.240 @member as 200 was pulled


how do I do that, I have it in the UMS in the universal firmware update, but don’t know how to apply it to a device?


Just drag and drop the firmware like a profile on your device, apply it now, wait 20 sec ar apply now on the endpoint. Then Right click device, Update & Snapshot commands, Update.


I updated it, Mic on keyboard still shows muted.


Then, please check if the xdotool command is doing the expected.


What is the command supposed to do? I tried it but the mic mute keyboard light is still on.


It should simulate the FN F8 key.

Did you checked if there is a Bios Update btw.?


I have not checked on the bios update, will do that

On the current bios.


From google:

Enable the microphone muting key

If your mute mic key (fn+F8) does not work, you actually just need to remap this key manually.

Here is an example of how you can do this by adding a custom mapping file:

/etc/udev/hwdb.d/61-hp-mic-mute-hotkey.hwdb

evdev:atkbd:dmi:bvn:bvr:bd:svnHewlett-Packard:pnEliteBook:pvr*

KEYBOARD_KEY_81=f20 # Fn+F8 on Elitebook, map to F20

askubuntu.com/questions/1138067/turn-off-the-mic-mute-button-light-on-hp-elitebook-840 askubuntu.com/questions/1138067/turn-off-the-mic-mute-button-light-on-hp-elitebook-840

seems like a general topic…


Where do I put this command in the UMS?


Only in a local terminal on Igel OS side. If one method works, I could create a profile for you.


Where do I do it on the OS side?


Where you executed the command I sent you, in a local Terminal.


Here is what I get

root@ITC3024A94D40EB:~# /etc/udev/hwdb.d/61-hp-mic-mute-hotkey.hwdb

bash: /etc/udev/hwdb.d/61-hp-mic-mute-hotkey.hwdb: No such file or directory

root@ITC3024A94D40EB:~#

root@ITC3024A94D40EB:~# evdev:atkbd:dmi:bvn:bvr:bd:svnHewlett-Packard:pnEliteBook:pvr*

bash: evdev:atkbd:dmi:bvn:bvr:bd:svnHewlett-Packard:pnEliteBook:pvr*: command not found

root@ITC3024A94D40EB:~#

root@ITC3024A94D40EB:~# KEYBOARD_KEY_81=f20 # Fn+F8 on Elitebook, map to F20

root@ITC3024A94D40EB:~#


Do you have a person around you who is a bit Linux skilled who might assist you on that?

The commands sent in the post need a few linux commands tricks.

The link mentionned, should be read like:

create a local .hwdb file with correct mapping in /etc/udev/hwdb.d/61-hp-mic-mute-hotkey.hwdb:


nope

I did it, and got this

root@ITC3024A94D40EB:/etc/udev/hwdb.d# ls

61-hp-mic-mute-hotkey.hwdb

root@ITC3024A94D40EB:/etc/udev/hwdb.d# sudo udevadm -d hwdb –update; sudo udevadm -d control –reload; sudo udevadm trigger

Reading file “/lib/udev/hwdb.d/20-OUI.hwdb”

Reading file “/lib/udev/hwdb.d/20-acpi-vendor.hwdb”

Reading file “/lib/udev/hwdb.d/20-bluetooth-vendor-product.hwdb”

Reading file “/lib/udev/hwdb.d/20-libgphoto2-6.hwdb”

Reading file “/lib/udev/hwdb.d/20-net-ifname.hwdb”

Reading file “/lib/udev/hwdb.d/20-pci-classes.hwdb”

Reading file “/lib/udev/hwdb.d/20-pci-vendor-model.hwdb”

Reading file “/lib/udev/hwdb.d/20-sane.hwdb”

Reading file “/lib/udev/hwdb.d/20-sdio-classes.hwdb”

Reading file “/lib/udev/hwdb.d/20-sdio-vendor-model.hwdb”

Reading file “/lib/udev/hwdb.d/20-usb-classes.hwdb”

Reading file “/lib/udev/hwdb.d/20-usb-vendor-model.hwdb”

Reading file “/lib/udev/hwdb.d/20-vmbus-class.hwdb”

Reading file “/lib/udev/hwdb.d/60-evdev.hwdb”

Reading file “/lib/udev/hwdb.d/60-input-id.hwdb”

Reading file “/lib/udev/hwdb.d/60-keyboard.hwdb”

Reading file “/lib/udev/hwdb.d/60-sensor.hwdb”

Reading file “/lib/udev/hwdb.d/61-evdev-macbook.hwdb”

Reading file “/etc/udev/hwdb.d/61-hp-mic-mute-hotkey.hwdb”

/etc/udev/hwdb.d/61-hp-mic-mute-hotkey.hwdb:37: Property expected, ignoring record with no properties

/etc/udev/hwdb.d/61-hp-mic-mute-hotkey.hwdb:38: Property expected, ignoring record with no properties

Reading file “/lib/udev/hwdb.d/70-joystick.hwdb”

Reading file “/lib/udev/hwdb.d/70-mouse.hwdb”

Reading file “/lib/udev/hwdb.d/70-pointingstick.hwdb”

Reading file “/lib/udev/hwdb.d/70-touchpad.hwdb”

=== trie in-memory ===

nodes: 4938760 bytes ( 123469)

children arrays: 1975488 bytes ( 123468)

values arrays: 3154496 bytes ( 98578)

strings: 2164817 bytes

strings incoming: 5102508 bytes ( 321642)

strings dedup’ed: 3014682 bytes ( 244652)

=== trie on-disk ===

size: 8680889 bytes

header: 80 bytes

nodes: 2963256 bytes ( 123469)

child pointers: 1975488 bytes ( 123468)

value pointers: 1577248 bytes ( 98578)

string store: 2164817 bytes

strings start: 6516072

root@ITC3024A94D40EB:/etc/udev/hwdb.d#


Following is an equivalent one-liner for try-out in a root shell: (if it works it can be put into a custom command)

`echo -e ‘evdev:atkbd:dmi:bvn:bvr:bd:svnHewlett-Packard:pnEliteBook:pvr*n KEYBOARD_KEY_81=f20’ > /etc/udev/hwdb.d/61-hp-mic-mute-hotkey.hwdb; udevadm -d hwdb –update; udevadm -d control –reload; udevadm trigger`


It did not work, mic still does not work, and mic on keyboard is lighted.


I think there’s a subtle space you have to put just before `KEYBOARD_KEY_81=f20`

There are this lines where the generator complains: _Property expected, ignoring record with no properties_”

In the ask ubunutu it’s not there, but in the source gist.github.com/HappyCodingRobot/df400e16d0615e98e2c1eee738925d0b github page they mention.


has a space

This is what I pasted into the vi.

/etc/udev/hwdb.d/61-hp-mic-mute-hotkey.hwdb

evdev:atkbd:dmi:bvn:bvr:bd:svnHewlett-Packard:pnEliteBook:pvr*

KEYBOARD_KEY_81=f20 # Fn+F8 on Elitebook, map to F20


The space is there, indeed, but, it’s a little ambigious like you put it. Do you mean that you put the full path to the file in the first line? Sorry if im pedantic here, just making sure.

Have you tried the one-liner I provided earlier? It shouldn’t give you the warnings (ignoring record with no properties) like in your test.


I put the path in as shown. saved it, and ran the sudo command.

Yes, I tried the one liner did not make a difference the mic was still muted (lighted up on the keyboard).

tested in Windows 10, and the MIC is not muted. IGEL mutes it


It looks like this may be an upstream issue

askubuntu.com/questions/1207527/no-microphone-in-ubuntu-18-04-on-hp-elitebook

So doing some more digging, it sounds like these use Intel HDA cards for audio, and some people have had luck playing around with the snd kernel parameters.

IGEL has some of these, and you can try playing around with them, but I don’t see the the kernel parameter that most people say fixes these.

“`snd_intel_dspcfg: dsp_driver=1“`

Honestly, if you haven’t invested in these devices I would look elsewhere. HP has had a poor track record in the past for supporting Linux and they tend to use a lot of custom firmware on the hardware in their devices.

If you are set on these devices, then you can look at the registry location below and try playing with some of the settings underneath to see if any help.

system.sound_driver.snd_hda_intel

@member can you try running the command below as root and see if the microphone enables?

“`set snd-intel-dspcfg.dsp_driver=1“`


That did not work. Unfortunately I have 12 of these, and can’t return them.


Yea, sorry after I sent that I looked and it looks like IGEL does that already. From what I read that gets the speakers working (which is probably why it is set in IGEL OS) and not the microphone.

If you have to use those, I would look at getting external USB microphones


There is a freshly new Private Build Firmware that should fix it. Sent you a PM @member

Continue reading and comment on the thread ‘Microphone is muted, and when I try to unmute via the keyboard the light never goes out?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: