My IGEL Cloud Gateway (ICG) appliance doesn’t have tomcat installed?

My IGEL Cloud Gateway appliance doesn’t have tomcat installed? I run “systemctl status tomcat” and it says that the tomcat.service loaded: not-found (reason: no such file or directory) active: inactive (dead). I looked in /etc/init.d and I don’t see tomcat at all….what am I missing here?

Learn more, read the entire thread inside the IGEL Community o Slack

Did you installed it or did you only downloaded the appliance itself? The Appliance is just a Linux Server where the dependencies are configured, the ICG needs to be installed on it

I deployed the appliance, and then ran the bin file to install it. The wizard said it finished successfully. However, I never got prompted to add a port number.

Can you provide the command you ran for the installation? In addition: please check the service with

systemctl status icg-server.service

instead of tomcat.

For Port check:

netstat -ltnp | grep 8443

./installer-1.03.110.bin keystore.icg

I ran chmod a+x installer-1.04.110.bin first

I did su root, and then installed the .bin file

Was it a fresh install or an update?

Oh, when I ran “systemctl status icg-server.service”, I see the service as Active (running).

when I ran “netstat -ltnp | grep 8443”, I see it in LISTEN

and it was a fresh install

Perfect!! Then you are done!

I should be able to access the portal then externally, correct?

Yes and no. Did you already set up the UMS <=> ICG Connection? If yes, then yes.

Of course, network, DNS, etc… should work

I tried to add ICG to UMS but got error

Is the port 8443 on ICG reachable from UMS side and the Hostname/IP you configured?

“Could not connect to Secure Gateway”. “I/O error on GET request for ‘https://IPaddress:8443usgFirst-authentication-ums’. Connect to IPaddress:8443 [IPAddress] failed. Connection refused.

That’s when I add the public IP address

when I try the internal IP address, I get this: “Could not connect to Secure Gateway:” “I/O error on GET request for ‘https://IPaddress:8443usbfirst-authentication-ums” Host name: ‘IPaddress does not match the certificate subject provided by the peer…”

Can you check the port with telnet or something similar? Seems like the port 8443 is not opened between ICG<=>UMS…

I can ping internally from UMS to ICG, but I can’t PuTTY into 8443.

Sounds like a Firewall / Network issue… Can you putty to port 22 (SSH)?

port 22 is being allowed

We’re on VMware and maybe NSX is blocking this type of traffic

How can I view the ICG internally? Just put IP on web browser and that’s it?

No, landing page is disabled. usually putty or telnet

It’s funny, but when I do try IPaddress;8443 on IE, I get the “do you want to continue with untrusted site”, and I click go continue, and then I get “The webpage cannot be found.” Can I enable the landing page temporarily for testing purposes?

Yes, but it’s a bit complicated to explain through Slack… Would you mind to open ticket at our support in parallel?

I wish I could, lol. I’ve yet to activate an account. I keep registering but I can’t receive email from IGEL to finish.

I think my company’s spam is blocking it

Maybe I can just call instead and they can create an account fo rme?

Damn! That’s not good😫

You’re telling me! lol

Yeah, you could but it’s a german number: +49 421 520942222

Btw, when register ICG in UMS, should I be using the local IP of the server, or the public IP of the server?

oh, thank you for your help!

Both are good, but in your case I would prefer the local one!

So, apparently there’s no firewall/routing issue found between UMS and ICG. I’m wondering if the ICG is just not set up right?

It could be… Which UMS Version is in use?

UMS console 5.07.110

I was able to get this fixed with support. It turned out that the ICG was running fine, it was just not able to register in UMS because the internal IP address didn’t have an internal DNS record. So, it couldn’t resolve DNS. After I added new forward lookup zone and A record, it registered correctly 🙂

Continue reading and comment on the thread ‘My IGEL Cloud Gateway (ICG) appliance doesn’t have tomcat installed?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: