Our Custom Partition downloads files as part of post install, after reboot /usr/lib/ folder is empied and app will not start. How do retain the downloaded data?


Good Morning, I am testing out the Firmware 11.04.240.01 and running into some problems I was hoping someone may be able to speed up the Solution. I have several CP’s that bring down Lib files into the /custom/filename area and as a part of the install it also copies it to the /usr/lib/filename and then runs the command “ldconfig” and this has worked from 10.04.100.01 all the way to 11.03.587.01 with no issues. I know that 11.04.XX images are on the new Kernel and wanted to see if anyone else has can across this problem. The install process works and everything is there but when I reboot everything in the /usr/lib/ area is gone and now the custom app does not start and or have access to lib’s that are needed. Any help would be appreciated!


Good afternoon Randel, just in case, CPs that were created prior to IGEL OS 11.04 may not work anymore because of removed libraries.

What gives:

ldd yourapplication | grep ‘not found’

on 11.04?


I am installing custom library files as they were not part of the earlier OS’s ether. But not when I install they just go away. If I manually do the same process and call them they work fine till I reboot then they go away again. just weird. This is for a Prox reader incase you want to know “libpcProxAPI.so.7.2.26” Something we use in our Custom Autologin Gina on our devices. Let me know if you want more details or the files to test with, happy to share.


You cannot install libraries into IGEL OS 11.04.x – you need to install these libraries to the CP and only symlink them into the system


Do you use a init script like these Randel?

kb.igel.com/igelos-11.04/en/setting-up-library-paths-via-script-32868905.html kb.igel.com/igelos-11.04/en/setting-up-library-paths-via-script-32868905.html


Here is a sample for MS Teams

github.com/IGEL-Community/IGEL-Custom-Partitions/tree/master/CP_Source/Unified_Communications/Microsoft_Teams


OK, So not being able to install libraries into the OS is new with 11.04.x, Good to know. I do use a init-script and I will make changes to symlink them into the system then, It the same CP I created when I first started learning so I am sure there are things I could have done better but it worked. I will let you know how it turns out. Thanks


Not really, let’s say it this way:

Our OS is in a Read Only mode (mostly at least). So if you copy a font to the endpoint, and you found a directory where you can put files in, they will most likely be gone after a reboot.

That’s why we have a feature called Custom partition.

Let’s start with my definition of a Custom Partition: the CP is a read/writable partition inside of our OS, where you can put files that shouldn’t get lost after a reboot. Those files could be scans (from a document scanner), bigger files (local emergency plans) or, the icing on the cake: scripts: imagine you could integrate easily Applications, Libraries that are not part of the Igel OS.

How does it work? In an easy manner explained: we receive a deb file (or whatever Linux x64 Ubuntu compatible), extract it, make it portable, and deploy it then to the endpoint.

So, basically, please forget the idea of installing stuff, that cannot happen because of our Read-only partitions and security checks BUT you can link everything you want to the OS during Boot time. Here magic starts (or ends)!

Steps:

we found every dependency of your application

we recreate the folder structure

create a script that links the needed files to our OS (example: ln -s /custom/anyconnect/etc/vpn.conf /etc/)

pack everything in a tar

create a profile where to download the CP, starts the script, etc…

Deploy it

On a simple library, no need to script a lot but we have to link into filesystem on every boot, that’s what the command sent above is doing. Hope that helps.

We didn’t changed that behavior since years…, the only things that changed (you were right):

Kernel version

Maybe other missing libraries


and last but not least: app armor is blocking some content

Continue reading and comment on the thread ‘Our Custom Partition downloads files as part of post install, after reboot /usr/lib/ folder is empied and app will not start. How do retain the downloaded data?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: