Philips Footpedal and 11.08.200


Hello everyone,

i have a problem with a philips footcontrol usb device.

Learn more, read the entire thread inside the IGEL Community o Slack

We try to connect it with citrix, but for me it seems like it doesn’t even gets redirected into the session.

On the igel it shows up as HID, so i tried it with and without additional device rules, but it doesn’t work.

The device itself shows as officially tested: kb.igel.com/igelos-11.05/en/philips-speech-42008869.html

Has anyone an idea what i could doing wrong or has a confiugration tip for me?

Kind regards, Oliver


Hi. which firmware are you using?

Could be related to this: igelcommunity.slack.com/archives/C8GP9JHQE/p1666946827099129 igelcommunity.slack.com/archives/C8GP9JHQE/p1666946827099129


Hello Sebastien, we are using 11.07.170 on the Device. I tried the spit on that version, but it still does not work.

I will update to 11.08.200. and test the same.

11.08.200. Does not work either..


Are you using USB Acces Control?

kb.igel.com/igelos-11.08.200/en/usb-access-control-69178136.html kb.igel.com/igelos-11.08.200/en/usb-access-control-69178136.html

Is any other device being able to get redirected?


USB Access Control is off

Before the split konfiguration I tried a webcam and it was redirected. Now i don’t even get that webcam with the specific pid/vid redirected…

For today i am off. I will test further on monday.


When you created the profile in 11.08.200, did you set it to “Connect” (Verbinden I think) or “Allow” (Erlauben)

Also, I would not recomend using USB redirection for webcam devices.


Hi Oliver,

You could choose 2 options for foot pedals.

1. Use USB redirection.

2. Use Philips Speech Extensions.

We use USB redirection because we want to use Philips Device Control Center to program the buttons inside the citrix session for another application?

We created following rules:

The second option would be to use the Philips Speech Extensions. For this u need to install the some software on your citrix servers. More info can be found www.dictation.philips.com/fileadmin/Products/lfh7445/ifu/extensions/en/setting-up-philips-speech-extensions/philips-speechexec-enterprise-or-philips-speechsdk-integration/philips-speechexec-enterprise—8-0-and-later.html www.dictation.philips.com/fileadmin/Products/lfh7445/ifu/extensions/en/setting-up%5B…]ation/philips-speechexec-enterprise—8-0-and-later.html

This setup works fine when you use Philips Speech Exec.

We also find it usefull to enable the “connectionbar” during troubleshooting because you can see the usb devices.

Important to know: I think you can’t use USB redirection and the Philips Speech Extensions at the same time 🙂

Hope this helps!


Hi Christopher, thank you. I changed the usb redirection from “allow” to “connect” and now the device ist getting redirected.

Hi Glenn,

thank you for your config. It helped a lot! I was also trying with Phlips Speech Extension, but unfortunately i couldn’t got it working that way either.

Now i tried it with usb redirection and changed it to connect and on the igel i can use the foot pedal. Do you use it on igel exclusively? I thought i could test it on a windows client with citrix and now, while it works on igel, it doesn’t work with a windows client.

The windows client shows the device as “policy restricted” with a greyed out redirect button.


Hi Olivier,

I was working on that last week🙂. You should do some registry stuff 🙂 .

You need to create an Allow Rule.

Still Working on the auto connect.

Continue reading and comment on the thread ‘Philips Footpedal and 11.08.200’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: