Problem sending key combinations via shadowing to our custom software on IGEL OS

Hi all, I’m facing problems with sending key combinations via shadowing to our custom software that is running on VMs that our thin clients are connecting to via RDP on OS10. Our software has functions for key combinations (for example ctrl+shift+f2 and ctrl+shift+f8). On our old thin clients (OS4 and OS5) it works just fine but our new OS10 thin clients seem to catch those key combinations or otherwise don’t want to send them through. Is there something special that needs to be configured in the profiles for OS10 thin clients that is different from OS4/OS5 thin clients?

Learn more, read the entire thread inside the IGEL Community o Slack

Hi Jean Noel, not sure if it fits in your issue, but System=>Registry=>network.vncserver.skip_lockkeys is enabled by default, you could try to disable it.

Hi Sebastian, thank you for your response. I’ve tried it out but unfortunately it didn’t help. Any other suggestions?

We are using x11vnc as far as I remember, I‘m on a business trip but if you have time and check a few parameters on google, I could try to get it working

Did you also tried another VNC Client (like Realvnc a.e.) does it work there maybe if you have a look on the viewer settings.

I’ve just tried out several VNC clients outside of the Igel UMS (UltraVNC, TightVNC and RealVNC). They all show the same behaviour as the VNC client inside of the UMS that is used for shadowing. At least I now know that it has nothing to do with the VNC client. I hope that you can find the parameter that needs to be set, I’m running out of ideas.

I‘m on a business trip, but I believe that we should get is solved. Can you open a terminal on a working client (where shortcuts work), login as root and issue

ps aux | grep x11vnc

and send me the output?

root@XXX:/# ps aux | grep x11vnc

root 14644 0.0 0.0 7116 568 pts/0 S+ 12:31 0:00 grep x11vnc

root@XXX:/# ps aux | grep vnc

root 3171 0.0 0.2 4124 1824 ? Ss maalis21 0:00 /usr/bin/vnc_ssl_connector -s -p 5905 -y 5900

root 3190 0.0 0.0 2020 280 ? S maalis21 0:00 /usr/bin/vncguistarter :0

root 3193 0.0 1.1 48680 10072 ? Sl maalis21 15:17 /usr/bin/vncgui –display :0

Didn’t find anything for x11vnc so I’ve tried to look for vnc

Me and a colleague did a thorough investigation on both an old thin client and a new one: We’ve found out that both are running the same version of x11vnc

x11vnc: 0.9.13 lastmod: 2011-08-10

Thanks! Could you also share the exact firmware versions you are testing with and a short comment like works / works not

And a last one: are you using somewhere securevnc and somewhere not?

Sure thing:

Firmware: works

Firmware: doesn’t work

Interestingly enough now that you mention it, on the new ones securevnc didn’t work so we turned it off, on the old ones it should still be turned on

your ps aux command told me that but I preferred to ask… Ok, it shouldn‘t really matter IMHO, but please do me a favor:

Reset a device with OS10 to factory defaults

Don‘t register it with your UMS

Set the VNC Connection („unsecure“ please) locally in Igel Setup

Retry to connect by using a standalone VNC client (that should guarantee the key redirection, has to be configured sometimes)

It doesn‘t have to be the solution but would put me in a direction or another😄

ADD INFO: and set the right Keyboard layout locally

Alright, thanks a bunch so far, I will try that out. Might take some time because the thin clients we’re working with are in Finland and I am in Germany. But we have our lab setup which I just need to clean up 😅. Will write again as soon as I’ve tried it out.

Continue reading and comment on the thread ‘Problem sending key combinations via shadowing to our custom software on IGEL OS’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: