Problem with a touch screen on Advantech Dlog on IGEL OS

Hello, I have a problem with a touch screen on Advantech Dlog.

Learn more, read the entire thread inside the IGEL Community o Slack

The problem is that the touch screen does not work. i Have made a video for demo.

I tried different setting on UMS… You have an idea ? Thanks !

Hello Jonathan, I guess that you already tried to calibrate it: touchscreen calibration application can be found under Application Launcher > System.

This thread might also help:

Hello @member,

I don’t see the settings (COM) on OS

Hello! Ok, seems to be removed on OS11, did the calibration help?

@member I don’t know to do that ? (i have clicked on “Touchscreen already calibrated” but same problem

Just have a look on the first paragraphe of my first answer👍

@member i have clicked on “Touchscreen already calibrated” but same problem

Just add an icon to Desktop by setting a checkbox on Desktop and then you can start the calibration process.

@member Oh ok sorry

Pas de soucis😄Hope that helps!

@member Another problem, calibrate app never start. i have try to reboot but same problem 🙁

What is the exact modelnumber of Dlog device?

@member I have try to add Navigator and same problem too… Dlog V8310

Can you check if the device has a valid License? Start, I:


@member Yes, see

I guess you already had rebooted the device, right? How many Ram is installed?

@member Yes already restart and reset the terminal. 4Go + i5

Beside the fact that you could try an upgrade to 11.03, I don‘t have a spontaneous idea, but I‘m on a customer Teamviewer session atm.

@member Merci 🙂 i update to the 11.03 and now the Navigator (Firefox) works but … not the calibrate settings 🙁

@member Bonjour, I tried various parameters but same problem 😕 You have no new idea ? Thanks

Not for the moment unfortunately but I saw that @member asked a similar question (I guess, your case) in our internal communication. Let‘s see if someone can answer it.

@member Oh yes, ok i am in contact with Ruiny. Thanks

Hi everyone,

@member not sure if you saw my last email, I was asking if you could try re-flashing your device with a 11.02 firmware and test again ?

@member I was in 11.02 then I migrated in 11.03, but the problem is the same

Hi @member You have a link please for Download OS 10 ? For try this :

Hi @member you mean for UDC2 (OS5) or UDC3 (OS10)?

Hum I don’t know the difference. OS10 I think it’s for test on dlog terminal

UDC2: is the older version of UDC from 2017:

UDC3 is the intermediate version from 2018:

@member thanks for all the information

Hi Jonathan, i have other Advantech touch screen monitors and have similar problems with calibration and getting double click to work. The only way to get it working is to install the touch screen drivers on the host Windows OS as well.

Hi @member thanks for this information i will try

Continue reading and comment on the thread ‘Problem with a touch screen on Advantech Dlog on IGEL OS’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: