Problems with IGEL UDC 10.x and Apple iOS 13.1.x Hotspot?

Hi, anyone encounter problems with IGEL UDC 10.x and Apple iOS 13.1.x Hotspot? At the moment we can establish a hotspot connection, but unable to browse. In the network config of the WiFi Adapter no Gateway is added? Anyone has an idea what could cause the issue? thx, br Harald

Learn more, read the entire thread inside the IGEL Community o Slack

Hi! No, just tested it on OS10.06.130 atm. and it worked! Die you already tested this version too?

Hi Sebastian, tried with different IGEL OS version, same issue. HotSpot conneciton works only once, after connecting to a different Wifi, and trying to connect to the hotspot again no correct ip address will be assigned. if we set ip settign manually conneciton is working. still have an open ticket with IGEL. br Harald

Ok! Thanks! Can‘t wait to get your feedback when solved by our support.

maybe the issue is Apple related, cause with iOS 13 changes has been done on network stack

Hi. We are having the issue. De3 problem is that IGEL not renew the ip adres. I run the next command via te terminal: root@ITC98E7F4EC303B:~# NIC=$(netstat -r | awk ‘/default/ {print $NF}’ | head -1); dhclient -r $NIC && dhclient $NIC

Killed old client process

<14>Nov 17 14:07:42 /etc/dhcp/dhclient-script: (wlan0) starting reason=RELEASE

<14>Nov 17 14:07:42 /etc/dhcp/dhclient-script: dhcp failure wlan0: RELEASE from

<14>Nov 17 14:07:42 /etc/dhcp/dhclient-script: (wlan0) starting reason=PREINIT

<14>Nov 17 14:07:42 /etc/dhcp/dhclient-script: (eth0) starting reason=PREINIT

<14>Nov 17 14:07:42 /etc/dhcp/dhclient-script: (wlan0) starting reason=BOUND

And if you can see there is a dhcp Failure.

Hotpspot iphone works correct with w10, Chromebook and Androis Phones.

@member thank you so much for that feedback. I tried with my Lab:


iPhone 7

iOS 13.2.2

that worked like a charm. Which versions are you using?

Hello Sebastiaan, UDC, Version 10.06.130, Iphone 8 iOS 13.2.3 . It works with iPhone 8 iOS 12 but after updated to iOS 13 the problem began.

Hello Ino, can you use a UD Pocket with OS 11.02.150?

Hi Sebastiaan, I can try. But that’s gonna be thursday. I shall let you know what the results are. Thanks for reply.

iam facing the same problem with my igel os 11 woth ios 13 hotspot

We discussed it on our Presales Meeting and atm. there is no consistent behavior. So, I would highly suggest to open a ticket to have it tracked in a proper way. Agree?

Hi Sebastien OS 11 has the same behaviour. I’ll already opened a ticket on november the 4th!!! ( [ITRS#2019110410000811) . But there is not much action on this one. For us its getting a problem because a lot of out employees are using the hotspot connection. Maybe you can take care that some action wil be taken soon.

I‘m on a business trip, but I will try to put an eye on it!

Hi There

can someone with an IOS >13.2.x check this troubleshooting:

(Reset network settings, logout and login again with icloud-acc)

Seems like an known bit off on apple.. 🙂

@member so I’m all for resetting the network settings on a device but it doesn’t make much sense when that devices works with other endpoints that aren’t running IGEL OS. In our case, this issue is also happening with different model iPhones and carriers.

@member I have a user with AT&T service that’s experiencing the same problem that you described. Users with Verizon and Xfinity Mobile don’t seem to have these issues. Resetting the network, as described above, did not fix the issue.

Hi together, i got a fix for the ios issue?

! instead of ?

Wow! Great! How did you fixed it?

add the attached script to a profile – System->Firmware Customization->Custom Commands->Base->Initialization – and reboot the client.

Is the idea that you would deploy this to all endpoints or on an as needed basis?

deploy to all endpoints

@member = Did that make any changes ad all in performace for you, i dont think it made any changes for my spring devices on 13.3 and the Igel OS

@member – what did you mean with performance?

Continue reading and comment on the thread ‘Problems with IGEL UDC 10.x and Apple iOS 13.1.x Hotspot? ‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: