Problems with Omnikey CardMan 3121 Smartcard Reader on IGEL OS 11.3.100

Hi Guys,

I have a problem with a Omnikey CardMan 3121 Smartcard Reader on IGEL OS 11.3.100.

Learn more, read the entire thread inside the IGEL Community o Slack

I need to redirect the Smartcard to a Citrix XenApp session to digitally sign documents.

I tried USB native Redirection without success… Tried to add the USB Vendor/Product ID and set the default rule to deny, no success. Tried to set the Smartcard PC/SC daemon with deactivated USB redirection (Device gets recognized when i locally open the Setup page on the IGEL Client) without success.

On Windows 10 i just have to plug-in the Card Reader and it gets redirected to the Citrix session without problem.

Has anybody an idea how to solve this?


Hi, when you write you tried PCSC which Middleware did you used? On German Datev Sticks I used the OpenSC

@member i used OpenSC. My smartcard is from (Italy) do i have to import the custom PKCS#11 module? thx

Yes, it might make sense, please download it, upload it to UMS by using the File function, set the Device File location in accordance and assign it then to your endpoint:


I’d be interested to see if this works

@member I downloaded now the PKCS#11 module vor Linux and tried the 64 bit and 32 bit version. Without success. Then i tried with native USB redirection enabled, no success… Is there a other way to to get this work? thx

You could try to use the fabulatech USB redirection or / and debug the PCSC stuff.

for Opensc:

OpenSC Smart Card

Parameter in the registry:

• scard.pkcs11.opensc.default.debug = 9

• scard.pkcs11.opensc.default.debug_file = /tmp/opensc.log


• journalctl

• /tmp/opensc.log

in Citrix Channel:

Citrix Smart Card Login

Parameter in the registry:

• scard.pcscd.debug

• ica.authman.tracingenabled = true

• ica.authman.loggingmode = verbose


• journalctl

• /userhome/.ICAClient/logs

Hi gyus,

sorry for the late response. I found out that the software was the problem. I installed a newer one, and now with IGEL OS I am able to sign documents. I created a Profile with Hotplug and Device Access rules enabled and activated the PC/SC Daemon located under Security-> Smartcard. Thx allot to all of you for your help!!!!

Continue reading and comment on the thread ‘Problems with Omnikey CardMan 3121 Smartcard Reader on IGEL OS 11.3.100’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: