Realtek RTL8821CE driver error: “wlan0: error fetching interface information: Device not found”

Anyone seen where devices are not seeing WLAN adapters within the IGEL OS? These are using the Realtek RTL8821CE driver. Some devices are connecting but most are not even recognizing that a wlan0 adapter is in the machine.

Learn more, read the entire thread inside the IGEL Community o Slack

wlan0: error fetching interface information: Device not found is the error received when attempting to enable via the secure terminal.

Not especially this one, but I would have to check the wifi chipset builtin and the driver we might use. Which firmware are you using? on both devices that do and dont work. uname -r shows both of the testers are on 4.18.20

From what I could research it looks like a year old issue with linux distros and this driver.

Correcting my above statement. It is just devices with that driver. The others are running an Intel driver.

Seems to be 8821ce and this one is intgerated. Just tried to modprobe and it worked (even if I haven’t the chipset to check entirely).

systemctl stop network-manager

modprobe -rfv 8821ce

modprobe -v 8821ce

systemctl start network-manager

It might sound weird, but did you checked the wifi country code, as a possible issue?

iw reg get

and set it here as needed? System,registry,network.interfaces.wirelesslan.regdb.continent

country 00:dfs-unset for the Country code.

Also when I attempted a modprobe I get module not found.

Then please update to 120, I tested on that version tbh.

Yep. Updating to 120 fixed it. Thanks!

You are welcome!!

Continue reading and comment on the thread ‘Realtek RTL8821CE driver error: “wlan0: error fetching interface information: Device not found”‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: