Redirecting a MFC Printer and scanner to Citrix via NAtive USB redirection

We’re having an issue since we went to Citrix 2207 with a Multifunction printer connecting when the session start and/or staying connected. We use full USB redirection since this is a multifunction. We changed Citrix policies from “Allow” to “Connect” for the vendor yet things just have been unreliable since then. Any ideas on how to start looking into making this stable like it was before 2207?

Learn more, read the entire thread inside the IGEL Community o Slack

Which firmware with 2207 are you using?


Would you be able to test a private build with 2209 just in case?

For sure

PM sent

Thanks! I’ll reply back. I’m not too hopeful because I didn’t see anything in the release notes that may address this issue for 2209 or even 2211 but always worth a shot. Not sure if your support team has had this addressed yet or heard of similar cases. I’ve considered trying to split the USB device to use CUPS printing but redirect IF1 and IF2 hoping that they’re the scanner.

It’s usually better to use native printer (CUPS) redirection for printers. It’s a more stable and reliable channel than generic USB.

Thanks Christopher. Do you know a good way to make multifunction printers work so users can take advantage of printing and scanning? I’m open to ideas. It was VERY stable before 2207 so Citrix by changing USB defaults broke something, however that’s the world we live in today constant change. The resolution is to unplug the device and plug it back in but management is growing old of that work around.

Scanning is always a challenge in VDI sessions. Because of the bandwidth and real-time data flow required it can cause other problems. The only thing that I have seen consistently work through different versions of Citrix is the Fabulatech Printer / Scanner redirection products.

The MFC because of scanning, I guess…

I can look into those products. We’re very cost conscious though so if I bring up a third party solution, I’ll get a heavy dose of “it worked all great until we updated FW, get iGel to fix it or get them to get Citrix to fix it”. Due to that I’m very open to all other ideas and workarounds. We’re looking into printer fimrware versions to try to catch a pattern, one idea is they fall asleep and the connection isn’t restored until the end user disconnects and reconnects the USB

Give 2209 a try, or this thread maybe:

Thanks Sebastien! Always appreciate your help. I think 2209 and the suggestion from Lars are great places to start. I’ll begin there

Here are some notes…

CUPs printing:

Native scanning:

The command to keep the printer from going to sleep has helped some, but it still requires us to disconnect and reconnect after the Citrix session starts. The printer is offline until that happens. I’ll try the test FW. I’m going to open a ticket, please keep in mind I have management on my side that says “it worked in the past, no excuses as to why it doesn’t work after an update” so that’s why I have to keep pushing this even though it’s an easy work around.

… If there were some way to wake that stupid printer up right before connecting perhaps, I don’t know. We also updated the FW on the printer. I understand this could be a Citrix change or even some sort of Linux / OS change that is causing this to behave different.

Okay – I was going to ask about the printer (manufacturer, model, FW version).

I have a Brother MFC-L2750DW at home. Brother released a FW version that causes it do go to sleep / offline and cannot wake up until I power cycle it. An updated version of FW came out that fixed it … and .. then they broke it again on next FW update.

Driving me crazy…

Very interesting. We don’t do regular FW updates on our printers, and we discovered this the day after a FW update rollout. Not sure if they can be rolled back but I can check. FWIW, I’ll have to push this one until it works or your team says we can not offer a solution and I have to create a paper trail of all of that. I know it’s frustrating because as you said it could be any number of reasons including these Brother printers.

*** Day after an iGel FW update rollout

Do you have documentation or even something like a forum thread discussing the Brother issue you personally ran into, that’s a good tree to bark up a bit

Let me check…

I opened a ticket with Brother …

Here is the ticket number with brother

Having to power down/up MFC to print [Incident: 220331-002593]

Thanks! I’ll report that up the chain as well. Decades in the industry and I’m still spending a large chunk of my day on printers. 😬

And this link…

Continue reading and comment on the thread ‘Redirecting a MFC Printer and scanner to Citrix via NAtive USB redirection ‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: