Scanner redirect for VMware stopped working with IGEL OS 11.05.120


I am currently using IGEL firmware 11.03.110. My scanner redirect for VMware works perfectly. I started testing with Firmware 11.05.120 and my scanner no longer is redirecting. I have a CP for VMware that disables usb redirection for the scanners we use. Put the PID and VID in for the scanners. I have usb redirection enabled with entries for the scanners in my scanner profile. I have tried searching the community and have not found a solution. This was also an issue when i was testing firmware above 11.03.110 and I have not had the time to do testing with new firmware until now. Any suggestions?


Do you see the Horizon scanner redirection tray icon in the remote windows session when using 11.05?


We have not used the the VMware Scanner redirection for VMware in the past. It would just pass thru as a device not a usb device with 11.03.110


The screenshot shows VMware Scanner redirection which explicitly doesn’t use any usb redirection but rely on the standard linux sane libs for scanner access and redirect on a higher level as basic usb transfers.

You might have missed it in the past, because you only see in the windows tray icon.

On the other hand you see if usb redirection is actually used and with which devices in the the vmware menubar.

But as soon you redirect the scanner using usb redir, the scanner will vanish from (the high level) VMware Scanner redirection.

But it depends on the scanner model if the linux sane libs are actually able to use the scanner. If not, then you have to use usb redir.


So I did some more testing. We are moving from win 7 to windows 10 in VMware with win 7 we let the scanner connect as a usb device and I can see it and it works with firmware 11.050120. with win 10 we do not want the scanner to connect as a usb device and use the usb redirection. with firmware 11.030110 the device is redirected but with 11.5.10 it is not. I have tried enabling sane support and no change. scanner is a Fujitsu fi-7030

The device sees the scanner not sure why it will not redirect.


You write: “with win 10 we do not want the scanner to connect as a usb device and use the usb redirection”.

I’m still not sure if you want to use native usb redirection or use the highlevel scanner redirection.

For the latter you have to make sure you also have the scanner redir support enabled in the Horizon agent in the remote windows session.

On the other hand it’s not needed to enable extra local scanner application support in the IGEL OS features.

This is because the sane libraries used for the Horizon scanner redirection are always available in the OS.


Update Sorry for the confusion. the scanner passes thru as a USB device. it works with a windows 10 persistent VM but not a non persistent VM. Tried SANE config did not work. I have a support case open will post the resolution once I have one.


Today I tried with a different fujitsu fi-7160. With both lowlevel usb and highlevel scanner redir. It was really a mixed bag. Both methods can work but it depends on the remote desktop and the scanner application. Really a new opportunity to sport my tag I want to popularize: #itsnotalwaystheclient (I’m biased of course, but it’s true 😉).

When you settle for usb redir, then the scanner driver needs be in the remote desktop only. The client only gives the raw usb traffic to the desktop, so you have to make sure that the desktop can handle it.


Thanks Jo. I am going to look thru our CP and make sure nothing is causing the issue.

It was the order of the CP that was causing the problem. Can see the scanners now.

Continue reading and comment on the thread ‘Scanner redirect for VMware stopped working with IGEL OS 11.05.120’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: