Slow performance after upgrading to IGEL OS 11.03.580?


Just an FYI. After updating some of my Igel clients to OS 11.03.580, several users complained of performance issues in Windows 10. The users who were still using OS 11.03.500 did not experience the same issues. After rolling back the updated clients, the performance returned to normal. I’ll just stick with 11.03.500 for now. Anybody else see this?


Which kind of Desktop / Application Virtualization Platform? How did that performance happened? I mean how would you describe it? Which kind of devices are affected?


We run Vmware and Citrix. The issue was an overall slowdown of the system. Response times within Windows 10. Opening the start menu or a program took much longer than usual.


Do you have any monitoring of those connections? Like can you see RTT, client side latency, etc.?


We use Solarwinds to monitor the virtual desktops, but nothing indicated an issue with CPU, RAM, or network. I’ve rolled back everything to 11.03.500, so I’m not really looking for a fix. Just more of a sharing of info. BTW, I could use remote desktop to the same vdi and performance was fine. It was only when connecting through the Igel client.


hmm, I bet if you tried just reverting the citrix workspace client would have fixed it. 11.03.580 defaults to Citrix Workspace App 20.04.0.21 and 11.03.500 defaults to Citrix Workspace App 19.12.0.19

although, it is interesting that 11.3.580 does not contain Citrix Workspace App 19.12.0.19 (according to documentation)


This is the same problem @member and i have. Hi. With receiver 20.04 very slow and many lags. Windows 10 XenDesktop and Server 2012R2 XenApp. Change receiver version back to 19.10 solves the Problem. Now still on 11.03.580 with old receiver Version. Any ideas why 2004 receiver has this problem and how to fix it?


Interesting. As I was updating all of our Windows 10 vdi, I also installed the VDA 1912. Maybe I’ll do some testing between VDA version and Igel OS version and see what the result is.


Same here – I suspect CWA 20.04 causes some issues, downgrade to 11.03.530 which has CWA 19.12 as default seems to solve the issue


Any news about this? In the last two private build release notes this issue was not adressed.


Has anyone tested the Private build with CWA 20.06? Does it still have the same slowdown issue as 20.04?


I have it installed, but haven’t been able to test it yet


I would continue the discussion in that thread, if you wouldn‘t mind:

igelcommunity.slack.com/archives/C8GP9JHQE/p1594020271020900 igelcommunity.slack.com/archives/C8GP9JHQE/p1594020271020900


Sure, absolutely!

Continue reading and comment on the thread ‘Slow performance after upgrading to IGEL OS 11.03.580?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: