Some IGEL OS devices will not upgrade during shutdown


Hello everyone, quick question when telling clients to upgrade their firmware when shutting down via a profile some clients just wont upgrade no matter how often they shut down. Is there a reason for this? Maybe im missing something?


Hello Ian, just in case: are your devices really shutting down or more going to sleep?

Could you provide a Screenshot of the settings of one of these devices, if you right click the device, Edit Configuration:

System, Update, Firmware Update?

Which UMS / Igel OS Versions?


Hello Sebastien, the problem occurs on pretty much every os version, UMS 6.05.

The profile in question is simply the activation of the update check on shut down. The firmware in question is assigned to the folder the clients are in.


I meant really the device configuration not the profile😊

That gives us a better overview about the config that the device received. Is a Bootsplash shown during bootup after shutdown?


Ah, heres the device config, im guessing you only need the firmware config?

About the bootsplash, im not realy sure, i think when we’re doing updates like this, and it works, the client does sort of a “mini” reboot; aka theyre rebooting to the bootsplash and then shutting down again.


Exactly!!

Yes, and just in case, could you show also the Power Options section?


These ones?


Yes and the shutdown section please.


Isnt that the second schreenshot i sent? Or is there another shutdwon section?


just an idea; on these devices, is there enopugh spaces to to the update?


Should be, since in the some folder with the same devices, or devices of the same type with same configuration, there are some devices that correctly download the firmware and update, while some others dont.

Could it have something to do with network speed? I can only see that all clients have a network speed of 100 mbits according to the UMS, but maybe some hav less and thats wy it doesnt work?


Right, sorry, the second pictures werent loaded. Hem… Just in case, can you reproduce it?


Mh.. ill have to be luck(or unlucky) and find one, i have some clients that i wanna update this evening, if theres one in there that has the error i can try and reproduce it. Should i record anything that could help you? Profiles, Screenshots or the like?


what devices are you using? Asking because for example in the past, I have some converted Dell Wyse that suddendly, without a real reason, stopped to shutdown properly and instead going to sleep.


All of them are UD3-LX 51 Clients, we also have some that are UD3-LX 60. But other than that we have no other clients, no converted Dells or UD pockets or the like.


Ok for devices; another thing I see is that you are updating to 11.03.587…is there a specific reason? The latest public is 11.04.240. Maybe trying with this change something …


We are currently using that version because it was the first one that worked perfectly for us, bevor we had the 11.03.500 and hat issues with dual monitor and changing monitor settings in general. But were currently looking into upgrading to 11.04.240, however we need to test it first, the 11.04.100 (i think) had some issues with our softphones.


I remember a Bug on that but can’t find the corresponding 11.0% version. Could you try to take a 11.04.200 and go to 11.04.240, just to test?


Sure thing

the hell, now that i wantedt to use my test client it worked again, it downloaded the firmware by itself and installed it…

Maybe i’ll keep it in mind that, when it happens again, i’ll record some stuff and ask again. Or try it out with a different version

Continue reading and comment on the thread ‘Some IGEL OS devices will not upgrade during shutdown’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: