The Remote Updater of ICG fails.

Forgive me if you think this post fits better in the igel-cloud-gateway channel, but here goes nothing 😅.

Learn more, read the entire thread inside the IGEL Community o Slack

Hello everyone!

I am facing an issue with updating our ICG. I followed the documentation from IGEL:, but after filling out the details on step 6 and clicking next, it runs for 22 seconds, only to timeout with the following message:

“Update of IGEL Cloud Gateway terminated with error:Exception occurred: Error transferring ICG installation package to remote WebDav, the hostname could not be resolved or an unidentified error occurred: Connection timed out: connect”

Ports 22 and 8443 are allowed inbound to the ICG, and I have verified that ssh to the ICG, from the UMS server, works with no issues. I attached pictures below of what it looks like when trying to update the ICG from the UMS.

Side-note: As of writing this, I noticed that the IGEL documentaton states that I should fill out an ICG port parameter, but I can’t seem to find it during the update process, nor is it pictured in the documentation.

Hello Nicklas,

all good.

Could you try to connect via SSH manually and execute the update by hand?

We had the same issue, even when trying a complete fresh install.

One ICG worked, the second did not.

After all I had installed it manually and connected it. This worked.

The manual download did the trick, thank you @member!

Continue reading and comment on the thread ‘The Remote Updater of ICG fails.’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: