Touchpad on ThinkBook 15 i3-10110U not recognized on IGEL OS

Hello everyone, we have ordered home office notebooks and now have the problem that the touchpad of the notebook cannot be recognized or used under IGEL OS. This is the ThinkBook 15 i3-10110U (ThinkBook 15-IML Laptop – Type 20RW) 8 GB / 256 GB model from Lenovo. I connected a USB mouse (Logitech USB Laser Mouse) to be able to control the notebook at all. The other device that is listed under Virtual core pointer will probably be the touchpad. See picture attached. How can we help each other now and what are the possibilities? It would be uncomfortable for us if we could not use the touchpad and would therefore have to complain about the notebooks either with an additional mouse and / or. Since I couldn’t find any Lenovo notebook results on the 3rd party hardware, at least not from affordable notebooks, I ordered the notebooks with a little risk and stomach ache.

Learn more, read the entire thread inside the IGEL Community o Slack

We have already tried the FN + key combination, with which the touchpad can be activated / deactivated, without any improvement.

I hope for quick support and thank you in advance.

In this case please raise a support ticket with igel. Not working touch pads could appear sometimes. Do you tried the recent firmware 11.03.110?

People on the net say, it’s working on *buntu after a BIOS/EFI update.

@member that’s a good point! Thank you.

First of all, thanks for the tip @member. We have carried out a BIOS update, unfortunately without success. The touchpad can still not be used. We then did another test under Windows 10, the touchpad didn’t work there at first. Only after installing the touchpad driver and Lenovo Energy Management. Now back to my question, is there a quick way to fix this problem or to install these two drivers under Linux? (I know the procedure with the IGEL support and this clearly takes too long for us or our GF. Which should not be meant badly.)

For some models the BIOS update seems to work, some had to update the Intel ME firmware, others fixed DSDT tables, …

So it might take some time until a general fix is available and included in the mainline kernel. Then maybe it will find it’s way to Ubuntu, probably in the next release.

So I thinks, it’s not that easy for Igel to fix that, sorry.

think @member had a similar issue with touchpads

Have you tried this? rmmod hid_multitouch run in the command line

@member I opened a support case many months ago, and the answer was “open a feature request”

I have tried your command @member , but I get the error message: “ERROR: Module hid_multitouch is not currently loaded.”

Hello @member – yes, a missing driver basically means a feature request. This is a normal step for IGEL to react to the flood of new hardware on the market. After the approval of this request the driver gets implemented in an upcoming release.

Following various approaches, we are now one step further, but we rely on IGEL. Unless we get a solution soon, we will have to switch to Windows because a notebook without a working touchpad and WiFi is useless. So I’m going to ask my question differently. In Ubuntu version 18.04. works the touchpad and wifi. Now my question, since IGEL OS on the older Ubuntu version 16.04. based, is there a way to migrate these drivers from the newer version to the older version or to update the Ubuntu version without great loss of time?

In Ubuntu for me works in all versions

@member I am not agree about feature request, because it works with rmmod in os 11 11.02.156 and not in next releases.

@member I have the same problem, error loading module

Maybe with more than a customer we can push to fix it

Yes, we could try that. Unfortunately, we cannot invest that much time. I can only devote a few hours to the whole problem today and possibly tomorrow, after which we have to give up and switch to Windows, which would be a real shame. However, we are under enormous time pressure from our management.

I called the IGEL support again and this time I got some useful information. In the roadmap the change to Ubuntu 18.04 is dated beginning / middle of April, so that our problem regarding the drivers should be solved from the moment and we now switch to Windows as a temporary solution.

New update for this topic: It seems so, that the IGEL OS version 11.04. with the new Ubuntu version will released not April, rather middle of May.

did 11.04 resolve the issue for you? We have some Lenovo 1-14ast-05’s with the same issue. Updating to 11.04 did not resolved. Funny, they worked with 11.03.500

A BIOS update solved the issue.

We solved running some commands at boot

can you share with me where you put the commands in the console and what the commands were? Thank you ! @member

yes, sure, let me find it and I will post it here

Thank you!

Continue reading and comment on the thread ‘Touchpad on ThinkBook 15 i3-10110U not recognized on IGEL OS’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: