Troubleshoot why I can’t UMS register a UDPocket through ICG?


Anyone know why I can’t UMS register a UDPocket through ICG? Or it fails. Can the firmware be to old? Firmware version: 10.04.100.01 (OS10). If so, how can I upgrade it without UMS? Just stole a picture that someone posted earlier as its exactly same errors.


Had this issue and it turned out our ICG logs were full and had to rebuild. Check your ICG log usage with df -h

Specifically check dev/sda1 to see if it’s 100%


May I ask if you have enough Free licenses for ICG? Especially for OS10? An update to 10.06.170 would make sense though…


Weird. I just created the ICG so I doubt the logs are full already


Cool – check Sebastien’s question above!


That’s a really good point. How could I even forget that we don’t have ICG-licenses at all 😂 This makes some kind of sense

So question: Device gets licence throught ICG? Because its not connected to the UMS


If you have some in your ILP or UMS, then yes!


Got the licence and ICG is connected but still Error: Failed to register the Thin Client at UMS. Checked logs in dev/sda1, only 2%. Other suggestions?


Did you updated the device to 10.06.170?


No. Keep getting “Failed to resolve host” when running the Firmware update locally on the Thin Client

What is the default values on the Firmware update profile? Like protocol and server name? I tried to connect to our local FTP server, but guess it works fine directly towards IGEL


www.igelcommunity.com/igel-firmware-updates-guide www.igelcommunity.com/igel-firmware-updates-guide

That should help, if the device is in the world wide web, please put the Firmware Update files on a public FTP or WWW Server. Through ICG you can‘t update devices directly from the UMS Webdav.


Yes, that helps with upgrading through UMS. I need to do it locally because the device can’t register in UMS.


kb.igel.com/igelos-11.03.100/en/updating-the-firmware-using-a-usb-storage-device-24385521.html kb.igel.com/igelos-11.03.100/en/updating-the-firmware-using-a-usb-storage-device-24385521.html


Downloaded www.igel.com/software-downloads/workspace-edition/#lightbox-form os_10.06.170_public.zip -> Extracted to the USB -> Can’t find osiv.inf files


Is the file on the Stick when connecting on a Windows client?

I mean the osiv.inf files:


Fixed it. Thanks


Exactly, the LX and OS versions differ on OS10, OS11 no difference anymore👍


Hi. I’m working with @member on this one. I’ve published firmware updates on an FTP server throught a Kemp VS. Struggling a bit with passive mode but we’ll get there.

Are anyone here familiar with publishing ICG throught KEMP (Or any other load balancer)?

Continue reading and comment on the thread ‘Troubleshoot why I can’t UMS register a UDPocket through ICG?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: