UMS stuck in ‘update mode’ when upgrading HA environment with 2 domains

If anyone is awake ๐Ÿ™‚ Upgrading HA environment with 2 domains. 1 domain shows upgraded, the other domain which has 2 servers shows not upgraded in the console, but locally when i launch it, it displays as upgraded. Console says they are still stuck in update mode. Anyone run into this before?

Learn more, read the entire thread inside the IGEL Community o Slack

Sure, since a few hours๐Ÿ˜„

Well, I know that it sounds weird, but can you check if a (windows) firewall is up and if yes, disable it and restart the Igel Services?

So you upgraded server 1, then 2, then 3, right? Which DB is in use when opening the UMS Administrator? SQL or embedded?

I just noticed this. For some reason it created an embedded DB and switched to this.

Warning: Do not make changes in the productive database during the update process. This is because decoupled servers work with a copy of the database schema in the meantime. For this reason, the update of all components within the UMS HA network should be carried out immediately. Implement a test system for the first installation of new IGEL UMS versions and check their processes before transferring them to the productive system. This also applies to hotfixes, patches etc. for server systems and databases.

Yeah, no changes were made during the update time. The one domain looks like it updated fine and its targetting the SQL DB. The other domain is using local DBs

You could check the install.log (Filesystem of the concerned UMS Server,Igel,Remotemanager) for some errors.

Yeah I don’t see any errors. All of them say x of 4 was updated. The one domain is completely fine, the other all the servers are stuck in update mode.

Uninstall/reinstall on the other domain and just rejoin from scratch?

Can you first try to reinstall the update? If there is a AV / FW in use, please disable it first.

Ill try to reinstall, but unfortunately i can’t disable those due to enforced policy. I checked the AV logs and nothing is being blocked. FW has all the necessary ports open but i can dig through those logs to see if any communication is being blocked

No go with reinstall. Still stuck in update mode

What is the the DB saying? can you switch it manually in UMS Administrator? When starting UMS Console, going UMS Administration, checking your UMS Servers/Loadbalancer: did you covered each of them?

Yep I upgraded all load balancers and servers that are listed in the console. I don’t see any activate buttons to change the db

I believe that opening a ticket would make sense then… Would you mind to keep us in the loop?

Yeah, I opened one but I am waiting to hear back. No way to escalate it im guessing?

a 3 day response time might be rough for a production environment -_-

There is always a way๐Ÿ˜‰ Do you have an Igel (Pre-)sales rep. contact? (S)he could do so!

If that doesnโ€˜t work, give me a PM with ITRS Number and I will try to help!

Just curious but what does this do:

Do you have a backup of everything? If yes, be brave, click on it๐Ÿ˜‰๐Ÿ˜

I’m still afraid lol

Still no response on the ticket ๐Ÿ˜ž When the final server upgrades and updates the DB, is it that server that sends the ok for the other servers to get out of update mode? And do you know how that process is done? Just searching for things that may be blocking it or causing it not to work cross domain

Usually, you start on server 1: wizard,click,finish, then server 2 until the last one is finished also. The last turns the maintenance mode off. I mean, you already rebooted DB Instance and UMS Servers I guess?! Checked the HA Communication ports:

AV is looking good, you said… I can try to check later on in my lab if I find the command to end the maintenance mode.

Interesting. Looking at the logs it shows that it sent the command to “Terminate_Update_mode” to all the servers. But only the one on the same domain turned off the update mode.

When sending “restart service” command from the UMS console, what account is used to perform the service restart on the server?

From what I recall: the SQL User!

Hmm interesting

So I was able to get them up and running, but there is a definite communication issue between 2 domains. Not sure if its our network or something else but I will discuss it once support calls me lol.

Workaround was basically go to the domain that was stuck in maintenance mode, click that “terminate update modus” (which is in german lol). This basically tells all the servers in the ha cluster to stop using the embedded db and switch to SQL (yes all of them, it made me panic at first). It will also stop the igelrmgui service. So you click that, restart the service, and it is back to using the sql db and back as “green” in the console and listed as updated. Fun day today ๐Ÿ™‚

@member: Did Support ever get back to you on this? I ran into it myself just now going from 6.03.130 to 6.04.100. After the upgrade, the load balancing status of both hosts was unknown and even after terminating update mode, I didn’t trust it. Started from scratch on 6.04.100 (new environment) and wound up with the same LB status issue.

Not yet. I still have a ticket open…

lol, wow. I guess you arenโ€™t planning on moving to 6.04.100 anytime soon then…

Was hoping to have it figured out by now lol. I’m not giving up though

If they ever get back to you, Iโ€™d appreciate it if you could share the results. Iโ€™m going to ask them about this issue when they email me back. Still canโ€™t believe that support is email only. Not off to a good start.

Sure thing

Continue reading and comment on the thread ‘UMS stuck in ‘update mode’ when upgrading HA environment with 2 domains’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: