USB webcam working in our Citrix desktop (1912 LTSR), running 11.03.580 (CWA 2004) not working for all apps


Trying to get a USB webcam working in our Citrix desktop (1912 LTSR), running 11.03.580 (CWA 2004). Is there still no 64-bit webcam redirection support in the Linux CWA? Skype appears to work, but our 64-bit BlueJeans doesn’t, and neither does our 32-bit Webex Meetings client.


Depends on the method you used to redirect the webcam


Just did one of these Projects, I used 11.04.240, CWA 2010 and started from here: kb.igel.com/igelos-11.04/en/webcam-redirection-and-optimization-37840007.html I used Option 1 (Unified Comms). The thing that caused me the most headache was the outdated VDA Agent on the machine itself, was 1903, once this was lifted to 1912 it all started working magically.


It’s way too early. Got HDX webcam redirection working in Skype and Webex using this:

That’s the guide I’m currently looking at now.

BlueJeans may be SOL then, since it’s a 64-bit app

So I’m clear, I can leave the above setting enabled, and also enable the Cisco Webex settings somultaneously? This would be in Option 1


For Webex, #1 should be the way to go, not sure if it can coexist with #2 fo BlueJeans


Okay, I see now that 11.04 is required for Webex. I’ll have to look into the later firmwares, because I saw weird issues in early 11.04 builds.

Well., this is one way to force me to upgrade, haha.

Appreciate the assistance.


11.04.240 made a really good impression on me, no weird things encountered so far. knocks on wood


I honestly don’t see a difference with 11.04.240 so far, which I guess isn’t a bad thing. Bluejeans still doesn’t work, but I kind of expected that. We’ll need this for Teams either way, so I guess this is the direction to go.

The weird thing is that Bluejeans detects the camera. In the past, I don’t believe it would have.


Detects the Camera by name or the ‘Citrix HDX camera’ or what its called?


Yep, shows up just like that. Same name that Skype, etc. detects it as. BJ is our only 64-bit videoconferencing app, though when Teams goes live next month, that too will be 64-bit.


Ok, its a start, so you see the camera name but dont get a picture at all, correct? If so, in Igel OS, you can also do a camera test, does this work?


Yep, no picture at all. This is in Imprivata appliance mode, so I don’t think I can test much on the IGEL OS side of things.


Oh, I see. Never worked with Imprivata so dont know much about that topic – one more thing you could try is USB redirection – although once you want to go for Teams that will most probably need a rework too

Continue reading and comment on the thread ‘USB webcam working in our Citrix desktop (1912 LTSR), running 11.03.580 (CWA 2004) not working for all apps’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: