Users who interact with AutoCAD will 100% of the time get a disconnect message sent behind the scenes on IGEL OS

Hello Everybody. This is my first post in the Community Slack, so if this is in the wrong location please let me know and I’ll delete and re-post.

Learn more, read the entire thread inside the IGEL Community o Slack

Does anybody by chance use iGel in their Citrix environment in conjunction with Nvidia’s GRID cards? We have a couple of weird issues for all users who have MCS desktops that are paired with the GRID card.

1) Users get random disconnects sent during standard use, such as writing emails, or operating a browser, or typing up a word document.

2) Users who interact with AutoCAD will 100% of the time get a disconnect message sent behind the scenes when they type in the “dist” function from within the AutoCAD program.

Neither of these issues occur when they have a Windows machine as their base OS when connecting to the Citrix environment

iGel OS 11 v11.01.130.01

Windows 10 v1809

Citrix Workspace VDA 1902

NVIDIA GRID Driver v391.81

Hey James, I had a customer with this issue. Citrix recommended going to receiver 1906. This receiver is in OS 11 firmware 11.02.100.

Can you try upgrading to that version and see if it helps?

Hi Christopher, Is that just on the iGel side or did it need the upgrade on the Citrix side as well?

Just the IGEL side, supposedly Citrix believes it’s an issue with the Citrix receiver for Linux

Excellent, thanks for the info. I’ll give it a shot.

Unfortunately it looks like the new firmware doesn’t resolve the issue. I’ve been trying to use a new UD2 with the updated firmware today and I’ve been randomly disconnected probably 15 times today.

Almost comically, I’m able to reproduce the issue with a single email from Alaska Airlines that just has plain text and a couple of URLs in it to their website for flights down to VMWorld

You could try to switch Server Policy “Use video codec for compression” to “For actively changing regions” as a workaround.

A real fix will hopefully shipped with Citrix Receiver 1910.

Hi James, same issue here – but only on IGEL Devices – can you reproduce the issue and the disconnects from a Windows Client using Citrix Workspace for Windows?

Are your IGEL devices running more than one monitor?

Hi Guys. Sorry for the late response. I took a day off and I’m at VMWorld right now. To answer your questions 1) It is not reproducible with a Windows client and 2) I have iGel devices running both single and dual monitor setups but it doesn’t seem to matter, as I can get the behavior on both types.

I hope you are enjoying VMWorld.

I had one more question if you don’t mind, and a possible thought based on a new Citrix client release.

Question: Can you send the make/model/specs of the devices?

Also, we may be dealing with an issue in the current version of the Citrix Workspace client that is in the IGEL firmware. It looks like the 1908 release fixes an issue with session disconnects when using Video Codec Compression. Curious if it sounds like this may be the issue?

Fixed Issue URL:

We are using VDA 1811, but maybe it isn’t related to the VDA Version. Do you know when Worksapce App 1908 will be published in an IGEL OS11 Firmware Release? It really could be this issue, yes…

Since the new receiver was just released yesterday, I do not have a date for it to be included. It will most likely have to go through integration and validation testing from IGEL. I am not sure how long this process will take, and it could vary if anything needs to be adjusted to support the new version.

Are you looking for the types of hardware that we primarily use? If so, it can be anything from old Optiplexes 7010-9020 to new Lenovo M series (majority) M700, M710, and just now starting to get a couple test units with the AMD ryzen (M625) I believe. Most of the use cases are being done with UD pockets but it is easily reproducible with the new UD2 Devices, which is what I’m using as my primary test device

OK, thank you @member there are some minimum requirements around HDX, but the New UD2 should definitely meet those.

No problem at all. I’m happy to help. Glad to get some visibility to the issue as I’d love to get the devices out to the 25 users I have that use the Grid card but as of right now with the disconnect problem I can’t. Appreciate the assistance.

So now I tested Ubuntu 19.04 installed on a INTEL NUC using Linux Workspace App 1908 and 1906 – no issues, cannot reproduce the problem. So its related to IGEL OS Firmware?

IGEL is based off the older stable release of Ubuntu, so it may be a difference in packages/base OS version.

I’m definitely still struggling with this one, so any additional ideas would be fantastic. I spoke with a few of the SE’s down at VMworld and after some ideas being thrown about. I’ve tried the following:

Testing on my full time unit of a new UD2

Adjusting Firmwares: Tried the last two, including the newest 11.02.130

Down revving the Citrix App from 19.6.0 > 13.10.0 > 13.5.0

Toggling the settings found at Citrix > Citrix Global > HDX Multimedia > toggling On/Off the Realtime Media Engine, Content redirection, Browser content redirection

I’ll randomly get disconnected doing mundane things like trying to RDP to a server, click on an email, open an attachment, open a file, etc

Tested with UD2 LX OS11 latest Release with Workspace 1906, still no issues

and I have been working on the issue for a few weeks and narrowing it down. It was marked as an engineering issue, and hopefully connected to another one that the iGel and Citrix teams are looking at

Hey James. I created a new Image for my customer using Win10 1903, Citrix VDA 1909 and NVIDIA GRID 9.1

Using OS11 with Workspace App 1906 – no issues or random disconnects for about two weeks. I think problem was a mix of all those listed components.

Thanks for the information @member! I’m not sure when we’ll move up to W10 v1903 for our desktops, but I can certainly take a look at the other pieces

Another question @member are your IGEL Clients in LAN connecting through StoreFront or in WAN / Internet connecting through NetScaler Gateway?

Sorry for the late response, a myriad of issues prevented me from responding…but we have the LAN clients going through Storefront.

I’m also happy to say that initial testing with the private build that has firmware version 11.02.158 and Receiver version 1910 seems to have resolved the issue. Going to continue testing and adding people slowly to ensure stability but it looks like the problem is resolved.

Continue reading and comment on the thread ‘Users who interact with AutoCAD will 100% of the time get a disconnect message sent behind the scenes on IGEL OS’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: