Using the IMI API for IGEL UMS, it doesn’t return any results.

When I’m running the api to check for thinclients, it’s not returning any results. can anyone assist?

Learn more, read the entire thread inside the IGEL Community o Slack

I ran the /umsapi/v3/thinclients after authentication and this is what I get:

“`HTTP/1.1 200

Content-Type: application/json;charset=ISO-8859-1

Content-Length: 2

Date: Wed, 20 Sep 2023 16:18:55 GMT

Connection: close

Server: []“`

Known bug from Igel, they are not willing to fix it though :man-shrugging:

I always test against the get Firmware endpoint, since you always have to have at least one of them

And there are other bugs with endpoints, one of them is getting all online-thin clients , here the workaround is to get all TCS w/o online status and then test each of those for the online status

So, i’m confused, it’s a known bug for it to not return any data?

and I’m not sure I understand the workaround, find the offline thinclients and test them?

i am linking 2 threads, so i dont have to explain it full length 🙂

…nr 2 follows …

For example, I even tried looking up a specific device ID:

Ok, so that thread. even the tcid doesn’t work

“`HTTP/1.1 400

Content-Type: application/json;charset=UTF-8

Transfer-Encoding: chunked

Date: Wed, 20 Sep 2023 17:50:25 GMT

Connection: close



“message”: “Device with ID <712> not found.”,

“errorCode”: “ITG-0A001”,

“time”: “2023-09-20T11:50:25.504”,“`


which UMS version? i can test tomorrow

and please provide the api request, so i can test the same


i tested already on 6.10.100 which worked

still not showing any records for me:

“`PS I:> Get-UMSDevice -Computername $igel -WebSession $WebSession

PS I:> Get-UMSStatus -Computername $igel -WebSession $WebSession

Exception calling “.ctor” with “1” argument(s): “Version string portion was too short or too long.”

At C:Program FilesWindowsPowerShellModulesPSIGEL.10.0PublicGet-UMSStatus.ps1:45 char:7

+ $Properties = [ordered]@{

+ ~~~~~~~~~~~~~~~~~~~~~~~~~

+ CategoryInfo : NotSpecified: (:) [], MethodInvocationException

+ FullyQualifiedErrorId : ArgumentException“`

so. now you got into another issue with my PSIGEL and used private fw versions 😄

please use the main branch from my github repo – there the version problem is fixed (and other features added) – but there is no new release (powershell gallery etc) since IGEL does not really care for the API atm – so i am not either right now

damn. that’s rough. thought this would just be a base feature for something like this 😕

the version from the github is from 2020??

is that right

you are absolutely right – imho this is normally a must have nowadays in an enterprise solution

the version I installed was from psgallery, but it’s showing the same version as the github..

latest version Aug 2022 last worked on

install via

last release from Apr 2020 (tahts also on powershell gallery)


so they aren’t doing released.

just commits.

dumb. lol

> the version I installed was from psgallery, but it’s showing the same version as the github..

yes there is no new version number – this i would only do if i would do a new release. so you would use the working-repo, if that makes sense

well if you think my work is dumb – you do not have to use it – i am out

Didn’t say the work being done was dumb, but that fact the last “release” was 2020, unsure why all the commits and work being done and being versioned correctly

because I have just now installed manually the copy you mentioned and still get the .ctor error on version

> unsure why all the commits and work being done and being versioned correctly

yeah, thats not how that works

> unsure why all the commits and work being done AREN’T being versioned correctly


fyi PSIGEL is my private project – it has nothing to do with IGEL as acompany and i am not an employee- this is unpaid voluntary work

I wasn’t aware of that, assumed it was community supported but owned by igel itself

Well, I am very appreciative of the work you have been doing and wish igel would recognize it and fix there own stuff based on what you’ve been doing

regarding the releases. a new release only gets done if all testing is beeing completed. this is not the case with the master branch of that repo atm (for reasons mentioned above). here are hotfixes / additional features integrated after issues were raised – there is no pipeline (building / testing / release) in place atm – so there is no release either.

that’s fair, sorry for jumping on ya like that!

the “.ctor version” thing should be gone for thinclints and firmwares BUT NOT for the status endpoint iirc .- this API endpoint is just completely wrecked atm

here the best solution would be to just delete the Get-UMSStatus function for now

hmm still not giving me results.

even looking for a specific device ID that is online like show above

only thing I can think of it’s the cert isn’t signed correctly. but even trying curl return the same results

have you uninstalled the gallery-version, or imported that github version via fqdn

“`Import-Module -FullyQualifiedName .PSIGELPSIGEL.psd1“`

to be sure that the correct version is used?

I uninstalled it and instead of doing what you have above, copied the latest release to the same directly where psgallery installs it so I don’t have to fight with the env variable

and you get the .ctor error when using the Get-UMSDevice function?

no no, I get nothing from there

literally just a new return line

but if I specify an ID like above it tells me it doesn’t match

the screenshot error comes from the UMS not knowing about a device with the ID 712 – which is along the lines of not knowing about any devices if request all of the devices..

do you get a result from Get-UMSFirmware?

yes, I just tried that and that worked

well ok – so the module in general works.

i would next try and do a curl request against the endpoint (or another RESTAPI client) direct to the enpoint and have a look if you get a result there

something like taht

“`curl –request POST –user ‘admin:W00t’ [server]:8443/umsapi/v3/login

curl –request GET [server]:8443/umsapi/v3/thinclients“`

only response is still `[]`

yeah ok – then its not on me 😉

is there ANY chance you doing request against the wrong UMS? well otherwise i dont know where the issue would be.

only have one 🙂

I thought the same thing, tried all hostname variants and IP address, also went on the machine itslef and did localhost

all same results

the only idea i have left is to update the ums and try again.

I sent a ticket into igel, maybe sometyhing is just goofed on the server or services as well

ya, that’ll be my next route

@member I am SUCH an idiot. 🙂

I forgot to assign permissions to the user I created to see the devices…

> permissions

well, i guess that’s another thing to the API – normally i would expect a “401” to that endpoint then, and not an empty result. lets hope IGEL comes up with a buttom-up new API in the future

but i am glad you found the issue!

Continue reading and comment on the thread ‘Using the IMI API for IGEL UMS, it doesn’t return any results.’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: