VPN connecting IGEL OS clients and Citrix Storefront issues


Hello, I am getting familiar with IGEL – Citrix Integration. I have Citrix Virtual Apps and Desktops installation in company lab environment. I could connect 2 Igel vm thin-client to citrix windows10 desktops in related store. I added server certificates to Igel vm thin clients and basicly my profile connects to Storfront Server. Then I installed an ICG server on AWS with an installation from UMS. I could register the third thin client which is outside of company network to UMS through the ICG server. I applied the same profile for this new thin client also copied server certificates into it. Everything is fine until this. This third thin client is running under Vmware Fusion on my Laptop. After establishing VPN connection to company network from the laptop, this third client can access storfront server from network (I verified this with network tool). But each time I initiate “Citrix Login”, I get this error: “Error adding store:AM_ERROR_AUTH_NETWORK_ERROR[65275]”. So the question is, do i need citrix netscaler or any additional component to work this configuration work? Or this should work with this setup>


Hello! Just in case: ICG is only related to Igel Communication and cannot route/encapsulate anything else then Igel Settings/Commands.Can you access the Storefront by using a Browser Session like Firefox instead?


Hi, thanks for your reply. I am trying to utilize my VPN connection to connect igel thin client and storefront. Inside of thin client I verified ping works against Storefront server. How can I run firefox inside of thin client??


You are welcome!

Sorry, got you wrong then. Which VPN solution are you using?

Firefox Session;

kb.igel.com/igelos-11.04/en/firefox-browser-session-32871173.html kb.igel.com/igelos-11.04/en/firefox-browser-session-32871173.html


Yes, firefox can connect tcp 443 of storefront server. My VPN client is Forti on my mac, thin client on Vmware Fusion bridged to that connection.

I guess the problem is DNS. I need to manually add a host record of this thin client. local thin clients get proper dns server from the dhcp but this third one get the ip from VPN server and this dhcp does not give the right DNS server.

yes it worked !

thanks!

Continue reading and comment on the thread ‘VPN connecting IGEL OS clients and Citrix Storefront issues’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: