Webcam are not being recognized in Webex and Webex Teams via Citrix on IGEL OS

Hello, we are trying to use Webcams in Webex and Webex Teams via Citrix. To achieve that we updatet a Thin-Cient to Version 11.4.270 and activated the Cisco Webex VDI Feature. The Cisco Network Test also says that the Client has a working connection to Webex but the cam ist still not being recognized. Is there anything else we have to do? (Using UD3-LX51 and LX60)

Learn more, read the entire thread inside the IGEL Community o Slack

Hello Julian, I would go through this great summary about any kind of settings on IGEL and VDI / TS side:

Thanks, I applied those settings but the webcam only works in Cisco Jabber. Not in Webex.

Do you have Native USB Redirection on?

It’s on but on “Deny”

And no exceptions set to ALLOW ?

Is the webcam working on the local Webcam test tool?

The only exception is a printer.

I didn’t know there is a local test tool. Where can I find it?

Our menu doesn’t show those icons, maybe it’s restricted. Is there a shortcut?

Create a new profile and there:

The entire menu with the Webcam-Tool in it is missing

Then just put the Shortcut on the Desktop instead of the System Menu

The Webcam works on the tool

Can you check which version you are running on VDI side? On Igel OS:


| Cisco Webex Teams VDI Client | |


| Cisco Webex Meetings VDI Client | “`

We are having a similar issue with getting Webex video to using Optimization. Cisco Webex has the following article on this subject “Cisco Webex Meetings Virtual Desktop Software” – Our Webex team has stated that ” Cisco Webex Meetings VDI Client |″ will not be available until 2/19/2021.

So I just want to add this thread. I have had Webex redirection working for some time now, updated my personal iGel from 11.04.240 to 11.04.270 and noticed that the Webex client wouldn’t pick up my webcam anymore and also noticed the client wasn’t running in VDI mode. I rolled back to 11.04.240 and reconnected to my session and it works correctly again. There seems to be an issue with Webex redirection in 11.04.270

I checked some configurations and Webex Meetings works now with Webcams but only with 11.04.240 not 11.04.270 (Thanks).

What I did:

• Downloaded the newest Webex-VDI Installer (

• Applied the IGEL config from the PDF that Sebastien sent

• Activated the Webex VDI Feature in the Webex admin center

• Added the reg-key ComputerHKEY_CURRENT_USERSoftwareWebExNativeVDI to our Citrix-Worker Registry

For Webex Teams (Doesn’t work yet):

• Added the parameters ALLUSERS=1 ENABLEVDI=1 ROAMINGENABLED=1 to our install script

Just wanted to note, that you shouldn’t have to activate the vdi feature in the admin center and set the reg key. Its either/or. I personally just do it through the reg key as I have Citrix users and non-citrix users and adding the vdi feature enabled for everyone does cause a slight delay when starting or joining a meeting if they aren’t using VDI. So for all my Citrix users, they get the reg key set but for laptop users (mostly execs) they dont.

We experienced the same situation. We wanted to upgrade to 11.04.270 because of workspace app 2012 but after that webex meetings breaks up. did ever get that running?

Oh, thanks for the information! Thought I needed both. I’ll change it to your solution.

So far Webex acts like the VDI feature isn’t enabled in 11.04.270. But since this version and 11.04.240 (Registry-Key needed to connect the Thin-Client to our network) seem to be a bit buggy anyways I’ll wait for a new realese before I roll out a new update.

That ́s how it also looks for me ….. it seems that the local webex-vdi-plugin on the igel isn ́t talking with the citrix session. If switching back to 11.04.240 webex works.

try 11.05.100, this worked for me now. I have tried WebEx Meetings Version and the previous

Thanks for the information! Already testing 🙂

Webex Meetings works for me too with 11.05.100. Webex Teams however still doesn’t work and I don’t know why…

Continue reading and comment on the thread ‘Webcam are not being recognized in Webex and Webex Teams via Citrix on IGEL OS’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: