Webcam is showing only still picture on IGEL UD3 / IGEL OS 11.03.110 within a Citrix session


UD3 11.03.110

We have a problem where the webcam only shows a still picture within an Citrix-Session. Anyone had similar experiences and have a solution for this behaviour?

Learn more, read the entire thread inside the IGEL Community o Slack


Hello, what webcam model and vendor are you using? Do you tried the webcam testing tool in the IGEL OS?

Webcam works fine in IGEL Tool, we already used different Webcam Models (Creative and Logitech).

Did you activate the HDX Multimedia and HDX Webcam and not using native USB redirection?

Are you using Skype for Business?

Yes HDX /w Webcam redirection is used but Real Time Media is not checked in IGEL Profile. No other combination got the webcam to work. However, RealTime Optimization is installed on RSH and Skype is used. Webcam works in Sype and 32bit Browser but only delivers still picture. We already tested an wide variety of Webcam settings in IGEL profile, no changes to behaviour so far.

Skype or Skype for Business? RTME only works and optimizes traffic if S4B is used.

Can you export the device setting and PM me?

The problem obviousily came from using the Applicance Mode. A classic Self-Service or Browser-Session worked now.

Perfect – the Appliance Mode is a “quick and dirty” way to secure the screen and offer access to the apps/desktop.

But I recommend to secure the IGEL desktop with a lockdown profile so you’re much more flexible for upcoming changes!

Continue reading and comment on the thread ‘Webcam is showing only still picture on IGEL UD3 / IGEL OS 11.03.110 within a Citrix session’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: