Welp with the RDS client USB drive mapping/native USB redirection in IGEL OS?

Can someone help me with the RDS client USB drive mapping/native USB redirection woes that I’m currently experiencing? I’ve been having some problems with card readers getting the first available 4 drive letters, which override the users network mappings. I have tried just about every setting available, and I believe the most elegant solution would be to use Igel’s “storage hotplug” or just native USB redirection but with a way to influence the drive letter.

Learn more, read the entire thread inside the IGEL Community o Slack

The issue with “Igel hotplug” is that any storage that I let hotplug, is inaccessible via RDS session (access denied) or does not get detected at all, depending on whether I leave the device plugged in while logging on.

Hi Ramon, I would advise the following:

use Native USB Redirection for smartcards, but deny for Mass Storage

use Storage Hotplug + Drive Mapping for USB storage

What is the Access Denied issue?

Alternatively, deny USB Redirection for smartcards and instead enable the PC/SC daemon

and use Native USB Redirection for USB storage

Thanks for your reply David,

I haven’t been clear enough. The “card reader” i’m talking about is for SDHC/Memory Stick or compact flash, not the traditional smart cards.

If I use native USB redirection, the drives get forwarded into the RDS session and function correctly, but the drive letters are not able to be influenced by any administrative process to my knowledge. This overwrites the users’ existing network drive mapping

If I use storage hotplug, the Igel OS makes a mapping in RDS of an arbitrary (mount)folder on the client, if i plug in a memory card, it looks like it’ll redirect the mapping to the memory card, but it gives me access denied when I try to access that memory card. If that can be fixed, i’m happy.

Additionally to the storage hotplug access issues, no matter what I do, the OS gives me lip about pulling out the memory card without properly unmounting it, even if I did.

I tried directly mapping a storage hotplug folder to /dev/sdc1 where the memory card gets mounted in the igel OS, but same result.

OK, simple solution: Enable USB Redirection, but DENY as default, then add a device-specific rule for the Card reader (I can show you how to do this if you need). The rest, you can set up Static mapping instead of dynamic.

How does that sound?

Denying everything by default will pose a problem for USB mass storage that is also used at this client. However, the card reader shows up as 4 different devices, I do know that the user only uses the SD reader portion, so as a workaround I can eliminate at least the other three by denying them and having only 1 device won’t overwrite the network maps. :thinking_face:

Static mapping gave the same error regarding permissions, i tried that already.

Update: The reader advertises in Windows as 4 devices, but in essence it’s only one. The thin client only recognizes one piece of hardware, which it forwards to windows, which makes 4 drives out of it.

Update 2: When configuring the thin client to deny usb redirection on storage, then enabling hotplug on static and turning off user browse local, i get a folder in the RDS session that I can access. every drive I add gets an extra folder, so that’s good. In essence it works but when I want to put this in a profile, the settings in the profile do not stick. Is there a reason for this?

the settings in the profile do not stick

could you be more specific? 🙂

The screenshot shows the icons that I get, not the blue/green icons but the blue ones, the settings that I enter in a profile with a blue icon get reset as soon as I save the profile (so my changes do not get saved) This way it’s impossible to make a profile for this setting

Anyone? 😅

Hi, that’s really strange! Maybe you have another profile which is is set to Override sessions?

Negative, I create a new profile and I only get the blue icon there, and the settings don’t stay. We try not to use Override because of it’s confusing nature. Maybe I should update the UMS before going too deep

Yes, what version are you on? build 40637

Ok. It would be good to update, even setting this current issue aside.

Agreed. I’ll get that going next week when most of my colleagues are in.

When exactly do you see that settings were not kept in the profile? When you click Apply, or when you re-open?

When I re-open it

Ok, do you click save or apply?

either or

I just made this new profile, setting the settings and saving, then re-opened.

Is the FW of the profile same as FW of the device?

No device involved right now, this is simply a fresh profile with only this setting, for demo purposes. This happens across different versions, currently

OK. Still sounds fishy. Do you have time for a quick call? If so, DM me your number!

Continue reading and comment on the thread ‘Welp with the RDS client USB drive mapping/native USB redirection in IGEL OS?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: