When configuring a profile for IGEL W10 Partial Updates, for the path, is it the full path to the specific partial update I want to apply?


When configuring a profile for Partial Updates, for the path, is it the full path to the specific partial update I want to apply? Or is it something else? Having a hard time getting a registry setting to be applied via Partial Update from a profile. If I select Partial Update from the Update & snapshot commands menu for a client, and put in the server / path, it works correctly. Am I missing something?


Here are a few samples, hope that helps!


Thank you Sebastien! That is what I have. However, I cannot get it to “take” unless I push via the Update & snapshot commands menu. I will say that these are older WES7 boxes, and I think I may need to just re-image them to the latest build.


Is there maybe a typo in your profile or: just in case: The base folder for all log files is C:IGELupdlog and C:IGELupd and there you should have a version history. Please delete from the file or change your version number in your manifest.lua.

If nothing changes (like a Rebuild in your UCB Tool), the OS thinks it has already been deployed and skips it.


Is the Partial Update port supposed to be different than the typical web port (8443)? I see yours set to 9080, and when I do a netstat on my server, I’m not seeing it listening on 9080.


Was just an older example where http 9080 (unsecured) was set as standard. https 8443 is still state of the art!


This is what I’m getting in the log:

“`06.11.2020 15:19:46 upd-get ERROR ERROR: cannot get package //ums_filetransfer/updates/DisableHardwareAcceleration: -2

06.11.2020 15:19:46 upd-get ERROR ERROR: executing of an update from: file:////ums_filetransfer/updates/DisableHardwareAcceleration“`

I have the server name and port configured in the profile, so this is super odd.


Can you share a screenshot of your profile?


Ok – I’m going to take a step back for a minute. This is a WES7 box. I’m going to update to the latest (yes, I know it’s a year old) firmware, and start from scratch. Rule out any oddities in this box over the last who knows how long it’s been sitting.

Upgraded to latest firmware, reset to defaults, and still not able to apply. Here’s a screen shot of the log from the device. Concurrently, I am also not able to apply the corporate background firmware customization.


Is the UPD.Log file present in file system? Could you delete and recreate it?


It is there because I created it. I get the error either way (missing, or after I’ve created it). One thing I missed was building the Partial Update. I have that done, and copied to my deployment folder. Still getting the error where the server name isn’t showing in the log. Changing over to HTTP / 9080 to see if that helps.

Well, progress! Changing to HTTP seems to have fixed the problem of it not showing up. However, the registry key still did not get created, and I have no upd.log file (and an error in the xplog.txt file), and my boot time on every boot is excessively long. I can connect via VNC shortly after boot, and get this screen for upwards of 5 minutes.

Switching over to deploying a reg file, rather than setting via UCB directly. Testing now.

Still the same problem =(. Reg key doesn’t get set. No upd.log, nothing in the xplog.txt file, and there is a 5 minute delay at boot. At least the IGEL spike change color to let users know _something_ is happening.


Hi Tim, could you try to re image one device with the standard 3.13.140 Snapshot, reset to factory defaults and retry?


Hi Sebastien, I did that, except with the 3.14.100 image. I can try again back to 3.13.140 to see if that helps.

Any time I have a Partial Update applied to a machine, the boot takes 5 minutes. I can VNC to it while it’s booting, and I get the IGEL loading screen. After it finishes booting, the setting is not applied. At this point, it’s easier / faster to push out an entire snapshot with my settings baked in =(.


But still no Reg key set?


Correct. Unless I set it in my snapshot, and deploy that to my device. Partial Updates are not working as far as I can tell. I even changed to using a reg file vs. registry key change, and that did not work, and I ended up with the same 5 minute boot delay.

Continue reading and comment on the thread ‘When configuring a profile for IGEL W10 Partial Updates, for the path, is it the full path to the specific partial update I want to apply?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: