When I start a video call via RDP, the IGEL client freezes immediately on IGEL OS 11

When I start a video call via RDP, the IGEL client freezes immediately.. any ideas why this happens and how to trace what went wrong?

Learn more, read the entire thread inside the IGEL Community o Slack


beside the idea, to update to 11.03.530, which kind of hardware/endpoint are you using? Which Call Software do you use?

Hi, I am using a Lenovo AiO with an integrated camera. Ich chedk it using the IGEL Firefox and a testpage.

I will fetch the latest update

i tried with the browser testpage, Teams and WebEx. All with the same result.

Updating the firmeware brings the same effect 😞

is there any kind of USB redirection involved?

I created one as I thought this is necessary

Shall I disable Native USB Redirection?

The session settings use Global settings where USB-R is enabled

Just in case, please disable the USB Redirection and retest. Is there any king of Remotx settings set? kb.igel.com/igellinux/en/performance-2275113.html

According to my other post today I enabled it.

Codexmode: use server settings

Code: Auto

Somebody recommended me to do so

I’m in calls alle the day, so didn’t checked the other posts. Please disable everything related to Hardware Acceleration, RemoteFX and retest. We just want to get the things sorted out, then we can adapt the config.

Ok, did that. Result is that the camera is not redirected to the RDP session

Ok, but are you able to receive a Webcall from another person?

I can hear and see the person. That worked before already. But I am not able to activate my own cam.

If I enable USB Redirection globally, the cam is not redirected

If I enable the “Rules” and click Allow, the cam is redirected

Do I have to create rules for this?

Let Remote FX and everything else disables, and

enable USB Redirection, Preset: Deny, Add the Webcam via a Device rule with the VID / PID and set this one to allow.

To retrieve the VID/PID, go into a terminal (Accessories, Terminal, +) and issue lsusb

0000:0000 is VID:PID

Thanks for the tutorial. Still freezes 😞

Is there any log that I can try to fetch?

Or is the rule case-sensitive? Means if Windows writes C457 it is c457 for IGEL?

Cause, if I go to “Device Manager”/ Clienst details, I can find the device ID for the camera with lower-case c

Freeze anyway..

It is not OS related. We have 2012 R2 and a 2019 farm.

Tested both.

You could try to set the debug mode in RDP, you might see the issue: please go to Registry, and set the Debug Mode:

rdp.winconnect.loglevel = DEBUG

Logfile: /var/log/user/rdp_freerdp%.txt

So you tried RemoteFX ON and USB Redirection OFF and on the other hand: RemoteFX OFF and USB Redirection ON, right?

@member Yes, with FX only, the cam isn’t even redirected. With USB-R it is, but causes the client to freeze when I try to use it.

Local usage works without issues.

The log file has not been created as it seems.

Could you also try to test the Webcam with another tool like a Website:

webcamtests.com webcamtests.com

I already did 😞

Then, please open a ticket and keep us in the loop please.

I will 🙂

Thanks for your support so far!

One last thing, did you had the chance to test another device/webcam ?

Is there maybe a helpful entry in the Event viewer on Server side?

Unfortunately not. Teams e.g.

acts like it succesfully started a video conference

I will look for another device to be tested

Continue reading and comment on the thread ‘When I start a video call via RDP, the IGEL client freezes immediately on IGEL OS 11’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: