When trying to connect IGEL OS devices to ICG I receive “Failed to get the certificate from the server”


Hello all, I’m trying to do a quick UMS/ICG setup test in our own cloud environment. I have set up everything and are able to establish a connection between ICG and UMS and also to the ICG from the internet with telnet on Port 8443. But when I try to connect an Igel OS Client to the ICG with the Cloud Gateway Agent Setup, I can’t see any connection to the ICG and get the error message: “Failed to get the certificate from the server”. As it is just a test, I used the self signed certificate and just an IP address. But I put internal and external IP in the cert as alternative names. Any suggestions on that? Is there any log file, that I could track? Thanks in advance Stefan


Hello Stefan, which versions of ICG/UMS/Igel OS did you used? Usually, you would only enter the public IP of your ICG Server for the keystore creation process, can you try that for testing?


Hi Sebastien, it works now quite fine. I was a bit stupid, as I tested the connection from my laptop, but had a wrong network setting in the VM running on that. So stupid… Thanks for your help.


😄Perfect!!


Hello IGEL community,

I have this issue setting up ICG for the 1st time. Ive confirmed connectivity to our ICG server. Cert looks good. I get “Failed to get the certificate from the server” message when trying to connect.

UMS 6.04.120

ICG 2.02.100

IGEL OS 11.04.130.01


Hello Brandon, self signed cert from UMS, your PKI, or a Public one?


Our own cert.


Just in case, Timesync is set on Client, UMS / ICG Server?

Did you created an Own Certificate for ICG or used a Wildcard one?


Yes timesync is set. Created our own.


Can you share a few screenshots?

Can you send me a OTP to check it from my lab? As PM of course

Hi Brandon, is Port 8443 from outside to your ICG opened?! I didn‘t got a connect…


Yes. I worked with our security team and confirmed 8443 is open.


Hem… a probeport is unsuccesful…

What does the following command gives back on ICG Server?

netstat -avn | grep 8443


I have to install netstat.

Ill get back you. Thank you for the help.

Continue reading and comment on the thread ‘When trying to connect IGEL OS devices to ICG I receive “Failed to get the certificate from the server”‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: