Citrix Storefront and encounter certificate issue on IGEL OS


I am testing the Citrix Storefront and encounter certificate issue. Following the KB, I did upload the CER to the UMS and assign to a Thin Client.

However, how can I tell it has been install ?


Hello David, you need to make sure you have all of the root, intermediate, and endpoint certificates deployed.

This means that you are missing one or more of those.

If it is a public URL you can send it to me and I can get the files and PM you with them 🙂


It is not public URL. It is internal company Citrix Portal. The company administrator created the certificate for me which I am not really sure whether it is correct or still something missing. What he did was, access the Citrix Portal using Internet Explorer in my UMS server and then Click on the certificate error and then got it installed. Then he launched Certificate Management in Windows to get it exported from my UMS server. I believe the 2 certificates I have is from the Citrix Portal. Got to check the End Point. At the moment, I just classify them as Undefined files so I can manually move them. Is there a way I can troubleshoot on my Thin Client whether those certificate installed ?

It is not public URL. It is internal company Citrix Portal. The company administrator created the certificate for me which I am not really sure whether it is correct or still something missing. What he did was, access the Citrix Portal using Internet Explorer in my UMS server and then Click on the certificate error and then got it installed. Then he launched Certificate Management in Windows to get it exported from my UMS server. I believe the 2 certificates I have is from the Citrix Portal. Got to check the End Point. At the moment, I just classify them as Undefined files so I can manually move them. Is there a way I can troubleshoot on my Thin Client whether those certificate installed ?


Navigate to it with a browser, and use the browser function to download every cert individually

if you use firefox, it will give it to you in the pem format which is 100% readable by IGEL


Managed to launch Citrix using Browser after export the certificate per the format here. kb.igel.com/igellinux/en/deploying-trusted-root-certificates-4237636.html

Suspect previously it was on another DER.

At least my Browser version is ok now. Got Citrix Self Service also running.

Still troubleshooting Citrix Storefront

Managed to launch Citrix using Browser after export the certificate per the format here. kb.igel.com/igellinux/en/deploying-trusted-root-certificates-4237636.html

Suspect previously it was on another DER.

At least my Browser version is ok now. Got Citrix Self Service also running.

Still troubleshooting Citrix Storefront


Yes, you need the Base-64. Once you have the cert you should be able to open it in a text editor 🙂

Remember, you need all of them in the chain

Continue reading and comment on the thread ‘Citrix Storefront and encounter certificate issue on IGEL OS’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: