On some IGEL OS clients “left-click” is not working


Hi there,

we face a weird problem with some Igel clients “left-click” not working when reconnecting to an active citrix session by using autologon.

To provide some context – we use UD3 with 11.04.240 and have some clients with the function to autologon and start XenDesktop once the server connection is established.

All works well. If the user disconnects from the session and logs on again it happens that the “left-click” ist not working anymore. Not only in the Citrix Desktop also on the Igel, also mirroring with UMS. If I restart the Session on the Terminal Server – everything goes back to normal


Hi! Is this behavior happening on Windows clients or not? Is the right click working locally (on Igel OS)?


On windows we don’t have this issue – right click is working as intendet. We figured out that we can replicate the problem if the igel reboots while a citrix session is active and the igel reconnects with the active session right after reboot


Does that happen if you switch the Citrix Workspace version?

kb.igel.com/igelos-11.04/en/citrix-client-selection-32870894.html kb.igel.com/igelos-11.04/en/citrix-client-selection-32870894.html

Continue reading and comment on the thread ‘On some IGEL OS clients “left-click” is not working’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: