Is it possible to uninstall the load balancing without removing the complete UMS installation?


Hi I was wondering, is it possible to uninstall the load balancing package of UMS 6 without removing the complete UMS installation?


@member interesting question 😉 You’re the first one.

Why do you want / need to delete the package?


@member just to be sure: you have a HA setup, with (let‘s say) 3 VM server.

On every server you installed:

the igel loadbalancer

the igel server

now you want to remove only the load balancer function from one server. Did I get you right? If yes, yes just remove the loadbalancer in our uninstall wizard.


Tnx for the quick reply, and yes I’ve got a HA setup with only 2 VM’s for now and both have the igel load balancer installed. Unfortunately, I cannot connect a device to the UMS. My colleague claims that it’s because of the load balancer. Though I suspect it’s because there is a VPN connection with NAT-ed addresses between the thin client and the UMS. Since locally on the thin client it gets an IP-address (say 192.168.0.15) and when I check Wireshark on the server and check on port 30001 I get a different IP-address from client (say 10.43.0.22) So the server tries to connect back by using 10.43.0.22. Got any ideas?


Why don’t you use the ICG?

this should solve the problem


We are already using an UMS server, which works but it is not HA setup. So, we thought we build a new setup since were using the current UMS server also for different customers which not need a HA setup. The customer who will be using the HA setup does use AD authentication trough the UMS server. And if the current UMS server has a problem the user authentication will fail, so we have a single point of failure.

If I look in the logs locally in the logs on the thin client while configuring UMS I get the message:

igelrm_agent [6940]: ** ERROR: Unexpected reply for local command: Error: Identifier of TC invalid

igelrm_agent [6940]: ** ERROR: cmd_register_to_dir: Failed to connect to rm server

But I can ping from TC to Server and also in browser I get OK if I go to IP-address to port 30001

See the attachment for the Wireshark log.


Is there a SSL Inspector in use between Endpoint<=>UMS?

How are you registering devices at the moment? Manual, Automatic, etc.?

What happens when you reset a device to factory reset and issue a manual registration from the command line (Accessories=>Terminal=>+) like this:

rmdb_register –help

USAGE: rmdb_register -s <server> -p <portnumber> -U <username> -P <password> -d <directoryid> -t <structure_tag>

Registration to server one or two, and see what happens.

What is about port tcp 30005 from UMS to Endpoint, is that one opened?

@member Apparently I made a mistake! There is no option in Wizard for uninstalling the loadbalancer separately. Thanks @member


@member @member Thanks for the quick reply’s, I’ve tried all your advices. I used Wireshark and asked one of our network engineers to figure out what happens. Eventually we found that the problem wasn ́t on the network layer but application layer. When I tried to add a TC in a test environment (same setup except servers and TC are in same network). I found out that I get same error and network activity when we tried to add the TC to the UMS (from TC setup menu) without user and password. When I used the database admin user and password we were able to add the TC to the UMS. 😊

In the current desired new HA configuration, I used a imported domain account user@example.domain.local since I made a connection with our DC. This account has in UMS all read and write permissions based on imported DC groups. But whit this user I couldn’t add the TC to UMS, so I created a new user (System->Administrator accounts) and also gave it all the permissions. And with that account we were able to add the TC to the UMS. 😊

After that we couldn’t push settings or push other commands. While using Wireshark we found that the server was using port 30005 to communicate with the TC. We thought port 30005 was only used for scanning for TC’s(devices) so we didn’t open it. 🙂

Maybe it’s possible to make a more specific error message when using wrong username/password when manually adding a TC to UMS. Only pop-up message we get was ‘Registration failed.’ And in the log files only message ‘Failed to connect to rm server’.

Once again thanks for the reply’s 😘

Long story 😛

Continue reading and comment on the thread ‘Is it possible to uninstall the load balancing without removing the complete UMS installation?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: