I reset a IGEL UD3 v10 to factory default and then scaned to bring back into UMS but get “Error: UMS License violation”


Does anyone know what can cause the following: I have a UD3 v10 that I factory reset and scan to bring back into UMS but get Error: UMS License violation


How did you reset the device? Locally or through UMS?

Can you provide UMS Version also?


both

albeit the messaging is slightly different locally


Ok, beside the UMS Version, can you provide the exact Igel OS Version?

We are speaking about a UD3 Igel device not UDC3, right?


UD3-LX41s, UD3-LX50s running either 5.13 or 10.05.100


Thank you! Can you provide a Screenshot / Picture of UMS / Device error?

Hem, ok. Strange… Can you open a terminal (Accessories,Terminal,+,Save), login as root, and make a screenshot of:

ls /licenses/dsa/licenses/

and then:

cat /licenses/dsa/licenses/thelicfileListedbefore


so when the device is already defaulted is there a pword


No, just enter.

Is it happening on one device or on several?


yes several


And they worked fine until Factory reset?


some yes, and others were off

On the ones that were just powered on and already in UMS would show up red


And what did the devices that “were off”? Or let me ask in another way: how many devices do you have in UMS? And how did you realized that something is wrong?


I first noticed a problem when we had some devices that were turned off and we needed to reconfigure them. We would usually do a factory reset then bring them back into UMS with the desired UMS profile setup

The background. We recently upgraded to UMS 6.02 and then added HA and LB roles then added a second UMS server


Can you please edit the lic file in a editor and check if mac address corresponds to the device?

Oh!!!!

That’s the turning point!! Please check if you have enough HA Licenses under UMS Administration, Global Configuration, Licenses, UMS Licenses


I don’t

so is that why this is happening?


Yes! Absolutely ! On OS10 you need to buy licenses for the using of HA. 5 CUL are free everything on top must be bought. Did you?


No, I didn’t know that

So, can I just remove the HA and LB roles


And every additional UMS Server you added… Or if you plan an upgrade to OS11, then you would have HA included by default without needing for paying additional fees.


so, in theory removing the roles on both UMS servers, will bring back to licensing functionality and thereby Factory resets would function as normal. Roughly how much are the HA licenses?


I didn‘t tried to revert a HA to regular for a long time, so, make backups of everything just to be sure (DB also, please). Removing every role server, uninstalling the last UMS Server and reinstalling without HA, should (no guarantee without beeing onsite) work.

Sent you a PM.


okay cool, thanks

Continue reading and comment on the thread ‘I reset a IGEL UD3 v10 to factory default and then scaned to bring back into UMS but get “Error: UMS License violation”‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: