Local printer redirection to a Citrix Session, not being redirected on IGEL OS 10 and IGEL OS 11


Hi guys, i have a strange problem regarding local printer redirection to a Citrix Session. With OS 5 the printer gets redirected without problems. With OS 10 and 11 the printer gets NOT redirected… I use the same profile for OS5, OS10 and OS11 Clients (Version 10.06..110.01). I tried to change some settings but without success… In the attachment you can find my configuration.


Hi Florian, are we speaking about the same terminalserver or an upgraded version? Did you had the chance to test different receivers/workspace apps maybe?


Hi Sebastien, thx for your quick answer 😁 It is the same Terminalserver. I tried different receivers and workspace apps… always the same result… Do i have to install the printer driver locally on the device?

thx


You are welcome, when speaking about printer mapping yes, on USB redirection (which I would assume isn‘t your case), no.

Hem, did you update the profile firmware for your printers, to the corresponding OS10 Firmware? If yes, could you try to recreate one of them from scratch on OS10?


The printer is connected via TCP. I tried now to create a new profile, without success. I connect via browser to the citrix session. Is there a possibility to set a Receiver version? THX


Have tried if the printer is working locally? E.g. printing from a local firefox session?


localy printing from firefox works

When i connect with Citrix storefront session, local printing works… Is it possible to add two Storefronts?


Regarding Receiver version (Sessions>Citrix>Citrix Client Selection), which one do you use?

Because I was trying to print in 10.06.110 and it looks like there is a printing problem which the 13.5.0 receiver. 13.10.0 and 19.3.0 are printing fine.


i tried all this versions, but with a browser session i was not able to print from citrix, localy it worked. Now i configured a Storefront Session, and now it works 😎


Great! About multiple Storefront servers: As there is only one set of login credentials, all servers you add to the list should accept it.


ok thx, when i create an additional Self Service login,i would non have this problems, right? Because there are two different domains and user credentials for both citrix sessions

Continue reading and comment on the thread ‘Local printer redirection to a Citrix Session, not being redirected on IGEL OS 10 and IGEL OS 11’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: